Bug 489595 - [StorageRewrite] - ValueError: pv is not in the device tree
[StorageRewrite] - ValueError: pv is not in the device tree
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:5adc4e5fe261888f1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 16:29 EDT by James Laska
Modified: 2013-09-02 02:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 14:12:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (54.22 KB, text/plain)
2009-03-10 16:29 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-03-10 16:29:52 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.26 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/__init__.py", line 521, in newVG
    raise ValueError("pv is not in the device tree")
  File "/usr/lib/anaconda/storage/partitioning.py", line 163, in doAutoPartition
    vg = anaconda.id.storage.newVG(pvs=pvs)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
ValueError: pv is not in the device tree
Comment 1 James Laska 2009-03-10 16:29:56 EDT
Created attachment 334711 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-03-16 13:50:16 EDT
We think this is a duplicate of the dev vs. devs bug (don't think that ever got filed, but Joel did commit a patch for it).  Can you try the latest build and verify that we've fixed this up?  Thanks.
Comment 3 James Laska 2009-03-16 14:12:03 EDT
I'm not seeing this with todays build.  I am now seeing bug#490296 which should be fixed in tomorrows images.

Note You need to log in before you can comment on or make changes to this bug.