Bug 489620 - yum - Cannot find a valid baseurl for repo: rawhide
yum - Cannot find a valid baseurl for repo: rawhide
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 19:10 EDT by Flóki Pálsson
Modified: 2014-01-21 18:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 10:34:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
result from #yum update yum (1.21 KB, text/plain)
2009-03-10 19:10 EDT, Flóki Pálsson
no flags Details
yum.log (32.33 KB, text/plain)
2009-03-10 19:12 EDT, Flóki Pálsson
no flags Details
log from yumex (1.80 KB, text/plain)
2009-03-10 19:29 EDT, Flóki Pálsson
no flags Details
chnages in changes infedora-rawhide.repo (984 bytes, text/plain)
2009-03-11 01:35 EDT, Flóki Pálsson
no flags Details

  None (edit)
Description Flóki Pálsson 2009-03-10 19:10:35 EDT
Created attachment 334727 [details]
result from #yum update yum

Description of problem:
It is not possible to update with yum ( and yumex and Update System ).
Error "Cannot find a valid baseurl for repo: rawhide"

Version-Release number of selected component (if applicable):
yum-3.2.21-7.fc11.noarch


How reproducible:
Always

Steps to Reproduce:
1.
# yum update yum
2.
3.
  
Actual results:
Error "Cannot find a valid baseurl for repo: rawhide"
See result in attachment #1 [details]
Expected results:
yum updated 

Additional info:
I installed F11 to day Mar 10 15:35:05 ( ca GMT ).
I installed yumex and started to update.
Comment 1 Flóki Pálsson 2009-03-10 19:12:41 EDT
Created attachment 334728 [details]
yum.log 

For additional information yum.log
Comment 2 Flóki Pálsson 2009-03-10 19:29:58 EDT
Created attachment 334731 [details]
log from yumex

log from yumex
Comment 3 Flóki Pálsson 2009-03-11 01:35:18 EDT
Created attachment 334751 [details]
chnages in changes infedora-rawhide.repo

With changes in fedora-rawhide.repo then yumex works.
See in attachment changed part and new part.
Comment 4 Flóki Pálsson 2009-03-17 17:09:54 EDT
yumex is ok now.
Now using 
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=rawhide&arch=$basearch
not 
metalink=https://mirrors.fedoraproject.org/metalink?repo=rawhide&arch=$basearch

It is possible that this was related to not updating rmp after installing F11 alfa.
Comment 5 Christopher Beland 2009-04-22 13:23:16 EDT
Had you edited fedora-rawhide.repo manually before?  Did you discover a file called fedora-rawhide.repo.rpmnew or similar?  If so, RPM was probably expecting you to integrate updates to this config file manually.
Comment 6 Flóki Pálsson 2009-04-22 13:46:26 EDT
>Had you edited fedora-rawhide.repo manually before?
No.
>Did you discover a file
>called fedora-rawhide.repo.rpmnew or similar?
I can not remember. I think so, and I can not remember to edit them.

I have reinstalled F11.
This has not been a problem since.
Comment 7 seth vidal 2009-05-11 10:34:02 EDT
closing since this appears to have been resolved on its own.

Note You need to log in before you can comment on or make changes to this bug.