Bug 489622 - abrt spews to the console
abrt spews to the console
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 19:39 EDT by Matthias Clasen
Modified: 2015-02-01 17:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-17 10:52:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2009-03-10 19:39:14 EDT
forgetting to close stdout, or somesuch ?

After running /sbin/service abrt start in some terminal, I keep getting debug spew from the daemon on that terminal. Stuff like 

CDebugDump::Lock(): waiting..................................................................................................................done.
CDebugDump::Lock(): waiting...done.

CDebugDump::CDebugDump(): /var/cache/abrt/ccpp-1236720909-4900 does not exist.
CDebugDump::Lock(): waiting...done.
CDebugDump::CDebugDump(): /var/cache/abrt/ccpp-1236720909-4900 does not exist.
Comment 1 Jiri Moskovcak 2009-03-11 06:59:55 EDT
Fixed in git.
Comment 2 Michal Nowak 2009-04-27 05:15:05 EDT
abrt is so chatty:

newman@dhcp-lab-124 ~ $ sudo /etc/init.d/abrt restart
Stopping abrt daemon:                                      [FAILED]
Starting abrt daemon: Plugin Logger (0.0.1) succesfully loaded.
Plugin Kerneloops (0.0.1) succesfully loaded.
Plugin RunApp (0.0.1) succesfully loaded.
Plugin Mailx (0.0.1) succesfully loaded.
Plugin SQLite3 (0.0.1) succesfully loaded.
Plugin Bugzilla (0.0.1) succesfully loaded.
Plugin CCpp (0.0.1) succesfully loaded.
Plugin KerneloopsReporter (0.0.1) succesfully loaded.
CRPM::LoadOpenGPGPublicKey(): Can not load public key /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
Registred plugin CCpp(Analyzer)
Registred plugin Kerneloops(Analyzer)
Registred plugin KerneloopsReporter(Reporter)
Registred plugin Mailx(Reporter)
Registred plugin SQLite3(Database)
Scanning for unsaved entries
/var/cache/abrt/ccpp-1239973618-17951
ccpp-1239973618-17951
/var/cache/abrt/abrt-db
/var/cache/abrt/ccpp-1239973512-17948
ccpp-1239973512-17948
/var/cache/abrt/ccpp-1240228890-27697
ccpp-1240228890-27697
Saving debugdeump: /var/cache/abrt/ccpp-1239973618-17951
CDebugDump::Lock(): waiting...done.
Saving debugdeump: /var/cache/abrt/ccpp-1239973512-17948
CDebugDump::Lock(): waiting...done.
Saving debugdeump: /var/cache/abrt/ccpp-1240228890-27697
CDebugDump::Lock(): waiting...done.
CCommLayerServer init..
CCommLayerDBus init..
CCommLayerServer::Attach
                                                           [  OK  ]
newman@dhcp-lab-124 ~ $ sudo /etc/init.d/abrt stop
Stopping abrt daemon: Got SIGINT/SIGTERM, cleaning up..
                                                           [  OK  ]

I can see it un terminal, when restarted on demand and in console while booting system (that's bad thing).

abrt-0.0.3-1.fc11.x86_64
Comment 3 Bug Zapper 2009-06-09 08:07:03 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Michal Nowak 2009-07-09 10:40:24 EDT
I believe this is fixed since 0.0.4 or in git at least.
Comment 5 Matthias Clasen 2009-07-09 11:54:35 EDT
With 0.0.4 in rawhide I still get:

[mclasen@planemask ~]$ sudo /sbin/service abrt restart
Stopping abrt daemon:                                      [  OK  ]
Starting abrt daemon: Plugin CCpp (0.0.1) succesfully loaded.
Plugin Bugzilla (0.0.1) succesfully loaded.
Plugin SQLite3 (0.0.1) succesfully loaded.
CRPM::LoadOpenGPGPublicKey(): Can not load public key /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
Registred plugin CCpp(Analyzer)
Registred plugin SQLite3(Database)
Scanning for unsaved entries
/var/cache/abrt/ccpp-1247146828-25296
ccpp-1247146828-25296
/var/cache/abrt/ccpp-1247146629-16684.lock
/var/cache/abrt/ccpp-1247146629-16684
ccpp-1247146629-16684
/var/cache/abrt/abrt-db
/var/cache/abrt/ccpp-1247146828-25296.lock
/var/cache/abrt/ccpp-1247146694-16756
ccpp-1247146694-16756
/var/cache/abrt/ccpp-1247146694-16756.lock
Saving debugdeump: /var/cache/abrt/ccpp-1247146828-25296
CDebugDump::Lock(): waiting...CDebugDump::GetAndSetLock(): dead lock found
Saving debugdeump: /var/cache/abrt/ccpp-1247146629-16684
CDebugDump::Lock(): waiting...CDebugDump::GetAndSetLock(): dead lock found
Saving debugdeump: /var/cache/abrt/ccpp-1247146694-16756
CDebugDump::Lock(): waiting...CDebugDump::GetAndSetLock(): dead lock found
CCommLayerServer init..
CCommLayerDBus init..
CCommLayerServer::Attach
                                                           [  OK  ]
Comment 6 Matthias Clasen 2009-07-09 11:56:13 EDT
Oh, sorry. I just notice that I still have abrt-0.0.3-1.fc11.x86_64
Any chance to get a 0.0.4 build into rawhide ?
Comment 7 Jiri Moskovcak 2009-07-10 04:09:22 EDT
Ah, I forgot to update rawhide. I'll do it ASAP (building packages right now).
Comment 8 Matthias Clasen 2009-07-17 10:52:18 EDT
Fixed in 0.0.4 for me

Note You need to log in before you can comment on or make changes to this bug.