Bug 489623 - abrt-gui doesn't find dumps
abrt-gui doesn't find dumps
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 19:45 EDT by Matthias Clasen
Modified: 2015-02-01 17:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-17 10:51:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2009-03-10 19:45:51 EDT
I kill -SEGV some process, e.g. gedit, and cc-applet starts blinking and annoying, but after I open the main gui, no crash information shows up.


abrt spews the following to the console:

CDebugDump::CDebugDump(): /var/cache/abrt/ccpp-1236720909-4900 does not exist.
CDebugDump::Lock(): waiting...done.
CDebugDump::CDebugDump(): /var/cache/abrt/ccpp-1236720909-4900 does not exist.
Comment 1 Bug Zapper 2009-06-09 08:07:15 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Michal Nowak 2009-06-09 17:57:04 EDT
Is there some specific reproducer, or it was crash in app started as root and then abrt-gui was started as normal user?
Comment 3 Matthias Clasen 2009-06-11 09:18:57 EDT
no, the app was started as a normal user iirc
Comment 4 Matthias Clasen 2009-07-09 09:43:11 EDT
I just tried this again:

install abrt, abrt-gui, abrt-ccpp, etc

enable abrt service

run some app in my session, e.g gedit

killall -SEGV gedit

gedit segfaults

I see the new dump in /var/cache/abrt, with the right executable, right uid, etc

run abrt-gui

...it comes up empty
Comment 5 Michal Nowak 2009-07-09 10:19:49 EDT
Version 0.0.4, right? I'd encourage you to run `abrt-cli --get-list` if it makes any difference but it started running just recently... -> Git
Comment 6 Jiri Moskovcak 2009-07-09 10:54:13 EDT
Try to run abrt -d, it will write debug messages to console. I have a feeling, that abrt just give up at the first error, so if there is some wrong entry from previous version it breaks. You can try to remove content of /var/cache/abrt/ and try to run it again.
Comment 7 Matthias Clasen 2009-07-09 12:13:32 EDT
I started from an empty cache dir...

But abrt -d is a good hint:

[mclasen@planemask ~]$ abrt -d
Plugin CCpp (0.0.1) succesfully loaded.
Plugin Bugzilla (0.0.1) succesfully loaded.
Plugin SQLite3 (0.0.1) succesfully loaded.
CRPM::LoadOpenGPGPublicKey(): Can not load public key /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
Registred plugin CCpp(Analyzer)
Registred plugin SQLite3(Database)
Scanning for unsaved entries
/var/cache/abrt/abrt-db
CCommLayerServer init..
CCommLayerDBus init..
terminate called after throwing an instance of 'DBus::Error'
  what():  Connection ":1.163" is not allowed to own the service "com.redhat.abrt" due to security policies in the configuration file
Aborted (core dumped)
Comment 8 Matthias Clasen 2009-07-09 12:14:27 EDT
Of course, that is just because abrt must run as root...

[mclasen@planemask ~]$ sudo abrt -d
Plugin CCpp (0.0.1) succesfully loaded.
Plugin Bugzilla (0.0.1) succesfully loaded.
Plugin SQLite3 (0.0.1) succesfully loaded.
CRPM::LoadOpenGPGPublicKey(): Can not load public key /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
Registred plugin CCpp(Analyzer)
Registred plugin SQLite3(Database)
Scanning for unsaved entries
/var/cache/abrt/ccpp-1247155921-7971
ccpp-1247155921-7971
/var/cache/abrt/ccpp-1247155921-7971.lock
/var/cache/abrt/abrt-db
Saving debugdeump: /var/cache/abrt/ccpp-1247155921-7971
CDebugDump::Lock(): waiting......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
Comment 9 Matthias Clasen 2009-07-09 12:16:00 EDT
Ah, and this is because abrt was already running...it should probably detect that.

After stopping it,

[mclasen@planemask ~]$ sudo abrt -d
Plugin CCpp (0.0.1) succesfully loaded.
Plugin Bugzilla (0.0.1) succesfully loaded.
Plugin SQLite3 (0.0.1) succesfully loaded.
CRPM::LoadOpenGPGPublicKey(): Can not load public key /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
Registred plugin CCpp(Analyzer)
Registred plugin SQLite3(Database)
Scanning for unsaved entries
/var/cache/abrt/ccpp-1247155921-7971
ccpp-1247155921-7971
/var/cache/abrt/ccpp-1247155921-7971.lock
/var/cache/abrt/abrt-db
Saving debugdeump: /var/cache/abrt/ccpp-1247155921-7971
CDebugDump::Lock(): waiting...CDebugDump::GetAndSetLock(): dead lock found
CCommLayerServer init..
CCommLayerDBus init..
CCommLayerServer::Attach
Comment 10 Zdenek Prikryl 2009-07-10 04:19:17 EDT
According to debug output, this is old version. A lot of bugs are fixed in 0.0.4, so please update abrt (it should be soon in repos). Also, make sure that a crashed application has same uid as an user who runs gui. Each ordinary user can see only his crashes (root can see all crashes).
Comment 11 Matthias Clasen 2009-07-17 10:49:25 EDT
Works for me now, with 0.0.4

Note You need to log in before you can comment on or make changes to this bug.