Bug 489640 - Filesystem on encrypted PV not fscked?
Filesystem on encrypted PV not fscked?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 22:56 EDT by Kevin R. Page
Modified: 2014-03-16 23:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-10 23:26:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin R. Page 2009-03-10 22:56:44 EDT
I'm concerned that my root filesystem isn't being fscked. Of course, it may be that it doesn't need to be fscked, but a good few things seem to have changed around F10 and I'm stuggling to work out what *ought* to be happening.

It's a laptop with an encrypted PV on which is an LV containing everything apart from /boot.

It's a laptop, so it gets rebooted frequently - I'm sure I've passed the maximal mount count, but I've not seen an fsck since upgrading to F10. I've also had to kill power due to bug #464866, and again, no fsck on reboot (does journal recovery always occur on mount, and is this sufficient for continued boot without fsck?)

Touching .autofsck doesn't seem to do anything (but neither is it cleared by anything), and shutdown -F seems to have disappeared.

(How should one force a fsck on F10, this doesn't seem to be documented?)

N.B. This is an upgrade to F10 with an existing encrypted root PV. It's possible some config has been mucked up somewhere - but even so, I'd hope initscripts would be more paranoid checking this type of thing...
Comment 1 Kevin R. Page 2009-03-10 23:26:07 EDT
Ok, so having worked out I needed to search around "upstart", I found I needed to touch /forcefsck rather than /.autofsck these days.

This forced a fsck on reboot, which relieves me of my major worry - that the FS might never be checked, even if it needed it.

(I'll put the gnome panel weirdness after an unclean reboot down to general fragility, rather than FS errors, which I can cope with less nervously ;)  )

Note You need to log in before you can comment on or make changes to this bug.