Bug 489655 - PNG8 converter doesn't work as expected
PNG8 converter doesn't work as expected
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ImageMagick (Show other bugs)
5.2
All Linux
low Severity high
: rc
: ---
Assigned To: Jan Horak
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 04:58 EDT by Lassi Pölönen
Modified: 2014-09-23 06:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 07:36:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lassi.polonen: needinfo-


Attachments (Terms of Use)
The orifinal test image (924 bytes, image/png)
2009-03-11 04:58 EDT, Lassi Pölönen
no flags Details
The result of the conversion (368 bytes, image/png)
2009-03-11 05:01 EDT, Lassi Pölönen
no flags Details

  None (edit)
Description Lassi Pölönen 2009-03-11 04:58:51 EDT
Created attachment 334761 [details]
The orifinal test image

Description of problem:
ImageMagick PNG8 converter seems to be broken

Version-Release number of selected component (if applicable):

rpm -q ImageMagick:
ImageMagick-6.2.8.0-4.el5_1.1

How reproducible:
100%

Steps to Reproduce:

1. See the attached image test1.png (black circle on a white background)
2. convert test1.png PNG8:test1_converted.png
3. See the converted image.
  
Actual results:
The converted image is ruined


Expected results:

The converted image should still contain a black circle

Additional info:
This doesn't happen with ImageMagick shipping with Fedora 8 or later.
Comment 1 Lassi Pölönen 2009-03-11 05:01:05 EDT
Created attachment 334762 [details]
The result of the conversion

Converted image attached
Comment 2 RHEL Product and Program Management 2014-03-07 08:45:14 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 RHEL Product and Program Management 2014-06-03 07:36:00 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.