Bug 489669 - configure-proxy.sh --noninteractive asks for user input
configure-proxy.sh --noninteractive asks for user input
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity low
: ---
: ---
Assigned To: Michael Mráka
Jeff Browning
:
Depends On:
Blocks: 456999 486216
  Show dependency treegraph
 
Reported: 2009-03-11 06:24 EDT by Michael Mráka
Modified: 2009-09-10 10:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:37:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Mráka 2009-03-11 06:24:50 EDT
Description of problem:
configure-proxy.sh asks for user in even in noninteractive mode.

Version-Release number of selected component (if applicable):
RHN-Proxy-5.3.0-RHEL4-re20090306.1 i386
spacewalk-proxy-installer-0.5.17-1.el4sat

How reproducible:
always

Steps to Reproduce:
1. install spacewalk-proxy-installer
2. /usr/sbin/configure-proxy.sh --answer-file=proxy-answer.txt --non-interactive
3. 
  
Actual results:
configure-proxy.sh asks for CA password while generating CA key and SSL key.

...
You do not have monitoring installed. Do you want to install it?
Will run 'up2date -i spacewalk-proxy-monitoring'. [N]: 
Generating CA key and public certificate:
CA password: 
CA password confirmation: 
Copying CA public certificate to /var/www/html/pub for distribution to clients:
Generating SSL key and public certificate:
CA password:

Expected results:
no user interaction

Additional info:
# cat proxy-answer.txt
VERSION=5.3
RHN_PARENT=
TRACEBACK_EMAIL=youremail@redhat.com
USE_SSL=Y
SSL_ORG="Red Hat"
SSL_ORGUNIT="RHN Satellite"
SSL_CITY=Brno
SSL_STATE=CZ
SSL_COUNTRY=CZ
INSTALL_MONITORING=N
ENABLE_SCOUT=N
RHN_PARENT=rhn.webqa.redhat.com
CA_CHAIN=/usr/share/rhn/RHNS-CA-CERT
Comment 1 Michael Mráka 2009-03-18 12:02:29 EDT
Fixed
commit 61d6efb3e31f4c73b6b439eef29e0a73c68ef641
    Automatic commit of package [spacewalk-proxy-installer] release [0.5.20-1].
commit 9f49f0efac3bf1315bc60aca6e375dcdf5c1b588
    489669 - rhn-ssl-cert shoud not ask in non-interactive mode
commit 319c5186718e5ebb5f1d23000ca466ef545994ee
    489669 - yum should not ask in non-interactive mode
Comment 2 Miroslav Suchý 2009-03-19 04:33:01 EDT
Assign this bug to Michael since he done the work. Since he cannot be developer and QA at the same time, resetting QA contanct back to Brandon.
Comment 3 Michael Mráka 2009-04-06 04:30:44 EDT
Moving ON_QA. RHN-Tools-5.3.0-RHEL?-re20090403.2
Comment 4 Jeff Browning 2009-04-23 16:29:22 EDT
Using the above example, configure-proxy.sh now asks for all input, even when using --answer-file and --noninteractive. It is behaving as though no switches were used at all.
Comment 6 Jeff Browning 2009-05-01 17:13:06 EDT
Verified
Comment 7 Miroslav Suchý 2009-08-27 09:18:32 EDT
[root@msuchy-client ~]# cat answer.txt
VERSION=5.3
TRACEBACK_EMAIL=root@localhost
USE_SSL=Y
SSL_ORG="Red Hat"
SSL_ORGUNIT="RHN Satellite"
SSL_CITY=Brno
SSL_STATE=CZ
SSL_COUNTRY=CZ
SSL_PASSWORD=XXXX
INSTALL_MONITORING=Y
ENABLE_SCOUT=Y
CA_CHAIN=/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
POPULATE_CONFIG_CHANNEL=N
[root@msuchy-client ~]# configure-proxy.sh --answer-file=answer.txt --non-interactive


no question given.

verified in stage on msuchy-client.lab.eng.brq.r.c
Comment 8 Brandon Perkins 2009-09-10 10:37:53 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.