Bug 489675 - Wacom tablet doesn't work over Bluetooth
Wacom tablet doesn't work over Bluetooth
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 07:02 EDT by Bastien Nocera
Modified: 2013-01-10 02:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 14:08:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshal-wacom-on.txt (153.87 KB, text/plain)
2009-03-13 21:40 EDT, Bastien Nocera
no flags Details
lshal-wacom-on-no-linuxwacom-fdi.txt (145.50 KB, text/plain)
2009-03-13 21:58 EDT, Bastien Nocera
no flags Details

  None (edit)
Description Bastien Nocera 2009-03-11 07:02:56 EDT
From the Xorg log:
(II) config/hal: Adding input device WACOM Pen Tablet eraser
(II) LoadModule: "wacom"
(II) Loading /usr/lib/xorg/modules/input//wacom_drv.so
(II) Module wacom: vendor="X.Org Foundation"
        compiled for 1.6.0, module version = 1.0.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 4.0
(II) Wacom driver level: 47-0.8.2-1 $
(**) WACOM Pen Tablet eraser: always reports core events
(**) WACOM Pen Tablet eraser device is /dev/input/event11
(**) WACOM Pen Tablet eraser (WACOM Pen Tablet eraser) is not a pad  
(**) WACOM Pen Tablet eraser is in absolute mode 
(**) WACOM: suppress value is 2 
(**) Option "BaudRate" "9600"
(**) WACOM Pen Tablet eraser: serial speed 9600 
(II) XINPUT: Adding extended input device "WACOM Pen Tablet eraser" (type: Wacom Eraser)
(**) Option "Device" "/dev/input/event11"
WACOM Pen Tablet eraser Wacom X driver grabbed event device
WACOM: unable to ioctl max values.
(II) UnloadModule: "wacom"
(EE) config/hal: NewInputDeviceRequest failed (1)
(II) config/hal: Adding input device WACOM Pen Tablet cursor
(**) WACOM Pen Tablet cursor: always reports core events
(**) WACOM Pen Tablet cursor device is /dev/input/event11
(**) WACOM Pen Tablet cursor (WACOM Pen Tablet cursor) is not a pad  
(**) WACOM Pen Tablet cursor is in relative mode 
(**) WACOM: suppress value is 2 
(**) Option "BaudRate" "9600"
(**) WACOM Pen Tablet cursor: serial speed 9600 
(II) XINPUT: Adding extended input device "WACOM Pen Tablet cursor" (type: Wacom Cursor)
(**) Option "Device" "/dev/input/event11"
WACOM Pen Tablet cursor Wacom X driver grabbed event device
WACOM: unable to ioctl max values.
(II) UnloadModule: "wacom"
(EE) config/hal: NewInputDeviceRequest failed (1)
(II) config/hal: Adding input device WACOM Pen Tablet
(**) WACOM Pen Tablet: always reports core events
(**) WACOM Pen Tablet device is /dev/input/event11
(**) WACOM Pen Tablet (WACOM Pen Tablet) is not a pad  
(**) WACOM Pen Tablet is in absolute mode 
(**) WACOM: suppress value is 2 
(**) Option "BaudRate" "9600"
(**) WACOM Pen Tablet: serial speed 9600 
(II) XINPUT: Adding extended input device "WACOM Pen Tablet" (type: Wacom Stylus)
(**) Option "Device" "/dev/input/event11"
WACOM Pen Tablet Wacom X driver grabbed event device
WACOM: unable to ioctl max values.
(II) UnloadModule: "wacom"
(EE) config/hal: NewInputDeviceRequest failed (1)


The device shows up in HAL, and in "xinput list":
"WACOM Pen Tablet eraser"	id=10	[XExtensionDevice]
"WACOM Pen Tablet cursor"	id=11	[XExtensionDevice]
"WACOM Pen Tablet"	id=12	[XExtensionDevice]

But "xidump -l" doesn't show it. I'm not sure what that "ioctl max values" is for. This is an A5 Wacom Bluetooth tablet.

linuxwacom-0.8.2.2-9.fc11.i586
Comment 1 Matthew Garrett 2009-03-11 08:51:01 EDT
Does it work on rawhide if you manually configure the device in xorg.conf? It looks like the hal setup is working fine, but the driver is bailing due to the ioctl thing.
Comment 2 Bastien Nocera 2009-03-12 13:30:52 EDT
Given the output from evtest, I doubt it would fully work...:
Input driver version is 1.0.0
Input device ID: bus 0x5 vendor 0x56a product 0x81 version 0x100
Input device name: "WACOM Pen Tablet"
Supported events:
  Event type 0 (Sync)
  Event type 1 (Key)
    Event code 272 (LeftBtn)
    Event code 273 (RightBtn)
    Event code 274 (MiddleBtn)
  Event type 2 (Relative)
    Event code 0 (X)
    Event code 1 (Y)
    Event code 8 (Wheel)
  Event type 4 (Misc)
    Event code 4 (ScanCode)
Comment 3 Bastien Nocera 2009-03-13 21:40:23 EDT
Created attachment 335186 [details]
lshal-wacom-on.txt

Seems to recurse adding new devices with the Bluetooth driver for the Wacom tablets. The driver doesn't rename the device, or anything funny like that.

$ grep -i wacom ~/lshal-wacom-on.txt | grep x11_driver
  input.x11_driver = 'wacom'  (string)
  input.x11_driver = 'wacom'  (string)
  input.x11_driver = 'wacom'  (string)
  input.x11_driver = 'wacom'  (string)
  input.x11_driver = 'wacom'  (string)
  input.x11_driver = 'wacom'  (string)
  input.x11_driver = 'wacom'  (string)
  input.x11_driver = 'wacom'  (string)
  input.x11_driver = 'wacom'  (string)
  input.x11_driver = 'wacom'  (string)
  input.x11_driver = 'wacom'  (string)
  input.x11_driver = 'wacom'  (string)
Comment 4 Bastien Nocera 2009-03-13 21:58:19 EDT
Created attachment 335187 [details]
lshal-wacom-on-no-linuxwacom-fdi.txt

With the linuxwacom fdi file removed. I believe it parents the new device wrongly, and thus loops over it somehow.
Comment 5 Bastien Nocera 2009-03-16 20:06:49 EDT
Seems to work fine now with a kernel that's not so crash-prone. Patch is at:
http://thread.gmane.org/gmane.linux.kernel.input/7078/focus=1749
Comment 6 Chuck Ebbert 2009-03-31 15:32:24 EDT
patch went in kernel-2.6.29-28.fc11
Comment 7 Bastien Nocera 2009-04-02 14:08:50 EDT
Working for me, thanks!
Comment 8 Tommy 2009-04-27 03:22:19 EDT
Hi, just to let you know I've written a proper HID driver for the graphire bluetooth. I've only tested it on Ubuntu, but if you want to try it out, I posted a link and some instructions at:

http://ubuntuforums.org/showthread.php?t=674738&p=7156808

Afaik the tablet works at a basic HID-compatible level without the driver - no pressure sensitivity etc.

With the driver everything should work just like a wired Graphire3.
Comment 9 Bastien Nocera 2009-04-27 04:49:32 EDT
(In reply to comment #8)
> Hi, just to let you know I've written a proper HID driver for the graphire
> bluetooth. I've only tested it on Ubuntu, but if you want to try it out, I
> posted a link and some instructions at:
> 
> http://ubuntuforums.org/showthread.php?t=674738&p=7156808
> 
> Afaik the tablet works at a basic HID-compatible level without the driver - no
> pressure sensitivity etc.
> 
> With the driver everything should work just like a wired Graphire3.  

It's not a "proper HID driver", given that it uses HID_COMPAT_LOAD_DRIVER(), and pokes at Bluetooth internals (hidp) directly.

I don't see why you would feel the need to write a driver when one was already written and sent upstream...
Comment 10 Tommy 2009-04-27 06:31:42 EDT
I wrote it because my tablet didn't work. Of course I didn't notice there was one written. I've been keeping the old driver updated and wrote the basis of this one back in December.

When I posted I was assuming that the only driver around was the (updated) old one by Andrew Zabolotny, so "proper HID driver" was in relation to that, not yours.

Anyway, as there's already more polished work available, no need for me to continue :).
Comment 11 Bastien Nocera 2009-04-27 08:59:46 EDT
I'd be happy to know if your tablet works with the patch I submitted upstream though (note that it requires a patch to bluez's bluetoothd as well).

Note You need to log in before you can comment on or make changes to this bug.