Bug 489696 - Evolution will stop opening e-mails after a while
Evolution will stop opening e-mails after a while
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
: 490946 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 09:43 EDT by Basil Mohamed Gohar
Modified: 2009-03-18 14:00 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.24.5-3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 15:39:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Basil Mohamed Gohar 2009-03-11 09:43:13 EDT
Description of problem:
Evolution will stop opening e-mails after a while.  It will display some messages as unread, but when I click on them, nothing happens.  The preview pane simply shows "Formatting Message".  This does not seem to end.

Furthermore, Evolution stops checking for new e-mails.

Moreover, it will not close unless it is killed.

Please advise me as to what information you might need to pinpoint this bug.

Version-Release number of selected component (if applicable):
2.25.5

How reproducible:
Happens every day, sometimes more than once.

Steps to Reproduce:
1. Start Evolution
2. Leave it running for around 6 - 12 hours
3. Try to read a message.
  
Actual results:
Evolution stops responding, message preview pane displays only "Formatting Message", and nothing else happens.

Expected results:
Evolution should display the message and mark it as read.
Comment 1 Milan Crha 2009-03-11 10:57:58 EDT
Thanks for the bug report. It's caused by my change in underlying library, which causes leaks of threads, and after some time you'll get out of memory. We are working on a proper solution for this at the moment. The only thing you can do now is to stop and start evolution again.
Comment 2 Matthew Barnes 2009-03-11 11:47:50 EDT
I have a potential fix for this, but I don't want to release it until I get some more confirmations.  Got a few people testing it now.
Comment 3 Basil Mohamed Gohar 2009-03-12 11:18:50 EDT
Thanks for replying to my bug.  I really appreciate the information, knowing that the bug is known, and also knowing that it is being worked on.
Comment 4 Fedora Update System 2009-03-13 12:37:21 EDT
evolution-data-server-2.24.5-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/evolution-data-server-2.24.5-3.fc10
Comment 5 Fedora Update System 2009-03-16 15:39:34 EDT
evolution-data-server-2.24.5-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Milan Crha 2009-03-18 14:00:28 EDT
*** Bug 490946 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.