Bug 489714 - Needs explicit versioned krb5-libs dependency
Needs explicit versioned krb5-libs dependency
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
x86_64 Linux
low Severity urgent
: rc
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2009-03-11 11:04 EDT by guilhem.bonnefille
Modified: 2009-09-02 07:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-09-02 07:26:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description guilhem.bonnefille 2009-03-11 11:04:14 EDT
Description of problem:
We are using cups with kerberos authentication required for ALL actions. But when we submit a job, cups stops with a "relocation" error on the log file. The relocation error concern kerberos version information.

We rebuild cups package from official RedHat source package, and everything went OK.

Version-Release number of selected component (if applicable):

How reproducible:
Simply submit a job

Steps to Reproduce:
1. Start kerberized cups
2. Send a job with kerberized client
Actual results:
Cups daemon stops due to relocation error.

Expected results:
Job is sent to printer and printed.

Additional info:
Our system is a RHEL 5.0 + updates.
This mix of version is certainly the origin of the problem. But, if so, the cups dependencies should be finer, and should identify the correct krb5-libs version required.
Comment 1 guilhem.bonnefille 2009-03-11 11:06:27 EDT
I found the exact message:

cupsd: relocation error: cupsd: symbol krb5_cc_new_unique, version krb5_3_MIT not defined in file libkrb5.so.3 with link time reference
Comment 2 Tim Waugh 2009-03-11 11:50:45 EDT
This sort of thing is normally sorted out automatically with library versioning, but in this case it doesn't seem to have worked.

The minimum krb5-libs compatible with cups-1.3.7-8.el5 is krb5-libs-1.6.1-31.el5.
Comment 4 Cameron Meadors 2009-03-18 12:25:37 EDT
what is the suggested fix for this?
Comment 5 Tim Waugh 2009-03-19 06:57:53 EDT
The suggested fix is to add this to cups.spec for the cups package:

Requires: krb5-libs >= 1.6.1-31
Comment 10 errata-xmlrpc 2009-09-02 07:26:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.