This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 489762 - Gtk+ "lpr" printing backend freezes the sub process [NEEDINFO]
Gtk+ "lpr" printing backend freezes the sub process
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk2 (Show other bugs)
5.3
All Linux
low Severity high
: rc
: ---
Assigned To: Benjamin Otte
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 14:21 EDT by guilhem.bonnefille
Modified: 2014-06-02 09:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:23:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (guilhem.bonnefille)


Attachments (Terms of Use)
Patch to close the io channel on unref at the end of printing (396 bytes, patch)
2009-03-12 12:17 EDT, guilhem.bonnefille
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 390159 None None None Never

  None (edit)
Description guilhem.bonnefille 2009-03-11 14:21:25 EDT
Description of problem:
I want to use kprinter as backend pour Gtk printing. But, when printing, kprinter stays freezed, until I kill its parent. The print process finish successfully when the parent process is killed.
This seems to be a not closed pipe in the parent.

The reason for kprinter is because I need to use kerberos with CUPS, but gtk CUPS backend does not support kerberos.

Version-Release number of selected component (if applicable):
gtk2-2.10.4-16.el5

How reproducible:
Always

Steps to Reproduce:
1. Configure ~/gtkrc-2.0 to enable lpr backend
2. start gtk-demo and launch a print test
3. once kprinter is opened, validate print in kprinter
4. kprinter freezed
5. kill gtk-demo
  
Actual results:
kprinter freezes until gtk-demo is killed. 

Expected results:
kprinter print the job, terminates, and parent process is still available for further job.

Additional info:
Comment 1 guilhem.bonnefille 2009-03-12 11:21:21 EDT
Seems to be related to the already solved #390159 on Gnome's bugzilla.
Comment 2 guilhem.bonnefille 2009-03-12 12:17:05 EDT
Created attachment 334958 [details]
Patch to close the io channel on unref at the end of printing

The following patch (based on the upstream commit) solves my problem.
Comment 5 RHEL Product and Program Management 2014-03-07 07:18:21 EST
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in the  last planned RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX. To request that Red Hat re-consider this request, please re-open the bugzilla via  appropriate support channels and provide additional business and/or technical details about its importance to you.
Comment 6 RHEL Product and Program Management 2014-06-02 09:23:12 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.