Bug 489764 - IPSEC will fail to work
IPSEC will fail to work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 14:24 EDT by Marc Milgram
Modified: 2009-04-01 01:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 01:40:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Milgram 2009-03-11 14:24:16 EDT
Description of problem:
xfrm_state_walk_done attempts to get a lock it already has.

Version-Release number of selected component (if applicable):
2.6.29

How reproducible:
Not attempted

Steps to Reproduce:
1. Attempt to connect via IPSEC
  
Actual results:
Suspect that it hangs

Expected results:
Works correctly

Additional info:
Found through code inspection.
Comment 1 Marc Milgram 2009-03-11 14:28:40 EDT
Here is the code from net/xfrm/xfrm_state.c:

void xfrm_state_walk_done(struct xfrm_state_walk *walk)
{
	if (list_empty(&walk->all))
		return;

	spin_lock_bh(&xfrm_state_lock);
	list_del(&walk->all);
	spin_lock_bh(&xfrm_state_lock);
}


That second lock should be an unlock.

This bug is also upstream.
Comment 2 Chuck Ebbert 2009-03-12 00:20:36 EDT
caused by commit 12a169e7d8f4b1c95252d8b04ed0f1033ed7cfe2
 "ipsec: Put dumpers on the dump list"
Comment 3 Chuck Ebbert 2009-03-27 20:58:50 EDT
In 2.6.29-16, sent upstream and acked by maintainer.
Comment 4 Chuck Ebbert 2009-04-01 01:40:42 EDT
The fix will be in 2.6.29.1

Note You need to log in before you can comment on or make changes to this bug.