Bug 489798 - Autofs broken for non-nfs network file systems
Autofs broken for non-nfs network file systems
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs (Show other bugs)
4.7
All Linux
high Severity high
: rc
: ---
Assigned To: Jeff Moyer
BaseOS QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 17:33 EDT by ewittmann
Modified: 2010-10-23 04:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:21:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff of update to patch colon escape of bug 428454 (1.29 KB, patch)
2009-03-19 13:12 EDT, Ian Kent
no flags Details | Diff

  None (edit)
Description ewittmann 2009-03-11 17:33:42 EDT
Description of problem:

As of autofs-4.1.3-234.x86_64, we are no longer able to use autofs to mount volumes on our Panasas StorageCluster using our PanFS kernel driver. 

Version-Release number of selected component (if applicable):

autofs-4.1.3-234.x86_64

How reproducible:

Upgrade from any previous version of autofs to autofs-4.1.3-234. Automount maps that previously worked with mappings like this no longer work.

Steps to Reproduce:
1. Update to autofs-4.1.3-234.x86_64
2. Create or use an existing automount map like this:
   mount1 -fstype=panfs panfs://panfs/path/to/mount1
3.
  
Actual results:

/var/log/messages entry:
Feb  2 08:53:35 machine automount[9453]: host panfs: lookup failure 1
Feb  2 08:53:35 machine automount[9453]: failed to mount /panfs/path/to/mount1


Expected results:

The automount should succeed, and has on previous versions of automount.

Additional info:

Am currently able to work around this issue by downgrading to the autofs provided by RHEL 4.0u5.

The issue seems to come from the following lines of code in autofs-4.1.3-pass-colon-escape-to-nfs-mount-module.patch:

-       if (!strcmp(fstype, "nfs")) {
+       if (strstr(fstype, "nfs")) {
Comment 1 RHEL Product and Program Management 2009-03-19 12:21:44 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 2 Ian Kent 2009-03-19 13:12:14 EDT
Created attachment 335890 [details]
Diff of update to patch colon escape of bug 428454

I've made this change to the original patch and made
a scratch build. It is located in
/mnt/redhat/brewroot/scratch/ikent/task_1732239 
and is revision 237.bz498798.1.

Could we get this to the customer for testing please.
Comment 3 Jeff Moyer 2009-03-31 10:52:22 EDT
We're awaiting testing feedback.
Comment 4 Issue Tracker 2009-03-31 13:42:21 EDT
The test kernel does correct the issue, and mounts work as expected.

Thanks,

Internal Status set to 'Waiting on Engineering'

This event sent from IssueTracker by bhamrick 
 issue 275420
Comment 14 Jeff Moyer 2009-04-09 16:23:09 EDT
Fixed in version 4.1.3-238.
Comment 19 errata-xmlrpc 2009-05-18 16:21:49 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0991.html

Note You need to log in before you can comment on or make changes to this bug.