Bug 489801 - [RFE] rss reader + notification bubble
[RFE] rss reader + notification bubble
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 17:56 EDT by Jóhann B. Guðmundsson
Modified: 2014-03-16 23:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-16 17:05:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2009-03-11 17:56:31 EDT
Description of problem:

Now the idea here is that we set up announcement page with rss feed cabability 
and an rss reader that would be integraded into gnome that would fetch announcement feed of this page and display it to the user via notification bubble or some other useful means to the end user. 



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2009-03-11 19:08:48 EDT
Infrastructure ticket created for the announcement page since we dont have one.

https://fedorahosted.org/fedora-infrastructure/ticket/1245

Come to think of it this is not a bad idea since corporation institution(s) that
are running Gnome desktop could deliver msg to it's employ since
well most of the publish their announcement via internal or external 
web

This could be ( if configurable ) to be used to provide the end user with 
ads hence money could be made of it.
Comment 2 Matthias Clasen 2009-03-11 21:06:51 EDT
Not clear how gnome-applets are involved in this at all.

I think the first steps here are better done in some other forum than bugzilla, e.g. the marketing list:

- Figure out what it is you want to announce, how frequent these announcements are, etc

- Determine what the appropriate form is for these announcements to appear on the users desktop: statusicon/notification bubble, dialog, browser start page...

- Worry about the necessary server-side infrastructure for this
Comment 3 Jóhann B. Guðmundsson 2009-03-12 04:37:34 EDT
Was not quite sure where to file it hence I threw it here you can move it to 
the appropriate component.

"I think the first steps here are better done in some other forum than bugzilla,
e.g. the marketing list:"

This has nothing to do with the marketing list this is about getting all announcements sent to fedora-announce-list@redhat.com onto a web page that 
supports rss or atom feeds and this application would fetch those feeds and
display it to the end user via notification bubble.

This is a means to provide the end user with announcement since we cant 
really expect nor guarantee the end user is subscribed to the announce-list

"
Figure out what it is you want to announce, how frequent these announcements
are, etc"

I personally am not foreseeing me sending any announcement but you can count all the announcements on the announce-list if you need some stats.

"Determine what the appropriate form is for these announcements to appear on
the users desktop: status icon/notification bubble, dialog, browser start
page"

We would add that announcement page of course to the list of fedora bookmarks in browsers we ship along perhaps having a link to it from start.fedoraproject.org and add it http://fedoraproject.org/ and hooked it to planet fedora.

Status icon/notification bubble is I think the way to go some small icon that that appears to the end user in the top panel when an announcement has been written on that web page. 

"Worry about the necessary server-side infrastructure for this"

Working on it
Comment 4 Jóhann B. Guðmundsson 2009-03-12 06:20:39 EDT
Found GNUsTicker ( Seems to be dead in the water  )

http://sourceforge.net/projects/gnusticker/

Screenshot

http://sourceforge.net/project/screenshots.php?group_id=135963

From that ( single ) screenshot I think it fits the simplicity of Gnome nicely

Perhaps the code from this could be reused in some way or form.
Comment 5 Bill Nottingham 2009-03-12 17:01:51 EDT
Why wouldn't you just use the default feeds in the browser?
Comment 6 Bill Nottingham 2009-03-13 14:41:10 EDT
OK, so the idea is to have some sort of almost 'alert' system to be used in addition to fedora-announce-list.

The problems I see are:

- you'd have an app periodically polling the network ; some people don't like
  that
- you want a system that doesn't just poll and notify people once, but track the notifications, store them, keep them around for review later (at which point, are you reinventing e-mail? Or QMF? or XMPP?)
Comment 7 Jóhann B. Guðmundsson 2009-03-14 00:14:06 EDT
"you'd have an app periodically polling the network ; some people don't like
that"

Not quite seeing how this logic can be applied here since we already do that
with updates and afaik application that periodically use some network activity 
have had the ability up to this point to turn it off.. 

"you want a system that doesn't just poll and notify people once, but track
the notifications, store them, keep them around for review later (at which
point, are you reinventing e-mail? Or QMF? or XMPP?)"

Not sure were this us coming from going to review the irc log later to see if I 
hinted some kind of archiving of those msq.

If you or anyone else has some kind of alternative solution to this dilemma
and that solution does not require some kind of massive back and fits all the *DE ( I think rss readers exist for all the *DE we support so as I see it should be the least hassle to implement this in all of them ) I like to hear it.

We need to start publishing the announcement(s) on the web anyway. 

This is what i saw as the easiest way to get the job done.

If you or others think this is not the right way to go and have a better solution then just throw in that idea for that solution here and then close this RFE.

I'm more concern about that we have the ability to deliver "alert(s)" to the end user instead if us wondering if this solution is the right one rather the some other one.
Comment 8 Bill Nottingham 2009-03-16 12:03:12 EDT
(In reply to comment #7)
> "you want a system that doesn't just poll and notify people once, but track
> the notifications, store them, keep them around for review later (at which
> point, are you reinventing e-mail? Or QMF? or XMPP?)"
> 
> Not sure were this us coming from going to review the irc log later to see if I 
> hinted some kind of archiving of those msq.

Only in the sense that you'd want some sort of way to review if the
user immediately dismisses whatever dialog.

> I'm more concern about that we have the ability to deliver "alert(s)" to the
> end user instead if us wondering if this solution is the right one rather the
> some other one.  

I think probably the best way is to get the RSS delivery up and going, and then we can experiment with different ways of getting the notification working client side.
Comment 9 Jóhann B. Guðmundsson 2009-03-16 12:11:04 EDT
Agreed 

I'll comment here when we got it up and running.
Comment 10 Jóhann B. Guðmundsson 2009-07-27 18:10:59 EDT
This is more or less what I had pictured in my mind.. 

http://www.quietearth.us/newsnotification.htm

we would of course update this code, strip it of all optional subscriptions  as in hardcode it only to have options  related to the fedoraproject. Like for example receive only security or general announcement and or subscribe to various announcements from sub projects within fedora.
Comment 11 Bill Nottingham 2010-02-16 17:05:59 EST
Closing this for now as it doesn't appear to be being worked. If it is, bring it up on the lists, file a Feature, or take the bug.

Note You need to log in before you can comment on or make changes to this bug.