Bug 489804 - no working networking in guests with qemu-kvm
no working networking in guests with qemu-kvm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 18:26 EDT by Jeremy Katz
Modified: 2009-03-16 11:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 11:07:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2009-03-11 18:26:41 EDT
After updating to the qemu-kvm packages, I don't seem to get working networking in my guests either if I use the usermode networking or with -net nic -net tap.  The network device shows up, but no apparent traffic and no dhcp lease.
Comment 1 Daniel Berrange 2009-03-16 08:45:23 EDT
Does regular non-usermode networking work correctly ? (eg tap based)
Comment 2 Jeremy Katz 2009-03-16 08:56:37 EDT
As mentioned initially, nope.
Comment 3 Daniel Berrange 2009-03-16 09:15:23 EDT
What guest OS are you running ?  I've just started an install of F10 x86_64  inside a F11 hosted guest, with qemu-0.10-0.9.kvm20090310git.fc11.x86_64. NetworkManager configured the NIC with DHCP and downloaded anaconda's stage2 image without apparent trouble.
Comment 4 Daniel Berrange 2009-03-16 09:21:00 EDT
Hmm, actually it seems to be slightly random, another guest install got stuck 30% of the way through grabbing stage2, and another on 90%. Guess I was lucky the first time.
Comment 5 Jeremy Katz 2009-03-16 09:44:28 EDT
I just saw that there's an update in today's rawhide for -0.9.kvm20090310, so my box is currently churning away at updates... this was with what was there last week (qemu-0.10-0.4.kvm20090303git.fc11 I think).  And I tried both with rawhide and F10 guests (livecds)
Comment 6 Jeremy Katz 2009-03-16 11:07:38 EDT
-0.9.kvm20090310git definitely seems better for me, at least in terms of what I was initially seeing.

Note You need to log in before you can comment on or make changes to this bug.