Bug 489824 - Testing jkeating.fedorapeople.org/boot.iso - TypeError: scanForMedia() takes exactly 2 arguments (1 given)
Testing jkeating.fedorapeople.org/boot.iso - TypeError: scanForMedia() takes ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:214f789da77762c45...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 21:11 EDT by James Laska
Modified: 2013-09-02 02:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 21:17:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (108.94 KB, text/plain)
2009-03-11 21:11 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-03-11 21:11:04 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.27 exception report
Traceback (most recent call first):
  File "/tmp/updates/yuminstall.py", line 447, in configBaseURL
    cdr = scanForMedia(self.tree)
  File "/tmp/updates/yuminstall.py", line 290, in __init__
    self.configBaseURL()
  File "/tmp/updates/yuminstall.py", line 1007, in doBackendSetup
    self.ayum = AnacondaYum(anaconda)
  File "/usr/lib/anaconda/backend.py", line 268, in doBackendSetup
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
TypeError: scanForMedia() takes exactly 2 arguments (1 given)
Comment 1 James Laska 2009-03-11 21:11:08 EDT
Created attachment 334880 [details]
Attached traceback automatically from anaconda.
Comment 2 Jesse Keating 2009-03-11 21:17:45 EDT
This was due to making an updates.img from the yuminstall.py file from the wrong branch.  I need to take the changes from master, apply them to storage branch and then make an updates.img.  New update pushed.

Note You need to log in before you can comment on or make changes to this bug.