Bug 489854 - more packages were installed by yum than expected: libgfortran
more packages were installed by yum than expected: libgfortran
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Corey Welton
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-03-12 06:23 EDT by Jan Pazdziora
Modified: 2009-04-29 07:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 07:22:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2009-03-12 06:23:07 EDT
Description of problem:

When installing Satellite-5.3.0-RHEL5-re20090306.2, warning

Warning: more packages were installed by yum than expected:
	libgfortran

is shown.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090306.2, i386.

How reproducible:

Tried once.

Steps to Reproduce:
1. # ./install.pl --disconnected --run-updater
  
Actual results:

* Starting the Red Hat Network Satellite installer.
* Performing pre-install checks.
* Pre-install checks complete.  Beginning installation.
* RHN Registration.
** Registration: Disconnected mode.  Not registering with RHN.
* Checking for uninstalled prerequisites.
There are some packages from Red Hat Enterprise Linux that are not part
of the @base group that Satellite will require to be installed on this
system. The installer will try resolve the dependencies automatically.
* Applying updates.
* Installing RHN packages.
Warning: more packages were installed by yum than expected:
	libgfortran
* Now running spacewalk-setup.
* Setting up Oracle environment.
* Setting up database.
** Database: Installing the database:

Expected results:

* Starting the Red Hat Network Satellite installer.
* Performing pre-install checks.
* Pre-install checks complete.  Beginning installation.
* RHN Registration.
** Registration: Disconnected mode.  Not registering with RHN.
* Checking for uninstalled prerequisites.
There are some packages from Red Hat Enterprise Linux that are not part
of the @base group that Satellite will require to be installed on this
system. The installer will try resolve the dependencies automatically.
* Applying updates.
* Installing RHN packages.
* Now running spacewalk-setup.
* Setting up Oracle environment.
* Setting up database.
** Database: Installing the database:

Additional info:
Comment 1 Devan Goodwin 2009-04-03 11:36:28 EDT
Can't reproduce in Satellite-5.3.0-RHEL5-re20090327.0-i386-embedded-oracle.iso.

After install:

[root@satellite ~]# rpm -qa | grep fortran
[root@satellite ~]#

Saw no such warning during install.pl.

Moving ON_QA.
Comment 2 Jan Pazdziora 2009-04-06 04:52:43 EDT
FYI, I can see the issues with Satellite-5.3.0-RHEL5-re20090403.2-i386 on RHEL 5.3. Here's a snippet of the rhn-installation.log:

--> Running transaction check
---> Package ant.i386 0:1.6.5-2jpp.2 set to be updated
---> Package jakarta-commons-el.i386 0:1.0-7jpp.1 set to be updated
---> Package jakarta-commons-modeler.i386 0:1.1-8jpp.3.el5 set to be updated
---> Package mx4j.i386 1:3.0.1-6jpp.4 set to be updated
--> Processing Dependency: axis >= 1.1 for package: mx4j
---> Package classpathx-mail.i386 0:1.1.1-4jpp.2 set to be updated
---> Package libart_lgpl.i386 0:2.3.17-4 set to be updated
---> Package libgfortran.i386 0:4.1.2-42.el5 set to be updated
---> Package gjdoc.i386 0:0.7.7-12.el5 set to be updated
---> Package eclipse-ecj.i386 1:3.2.1-19.el5 set to be updated

Are the versions of the other packages the same in your case?
Comment 3 Devan Goodwin 2009-04-06 08:37:47 EDT
I've got:

ant-1.6.5-2jpp.2
jakarta-commons-el-1.0-7jpp.1
jakarta-commons-modeler-1.1-8jpp.3.el5
mx4j-3.0.1-6jpp.4
axis-1.2.1-2jpp.6
classpathx-mail-1.1.1-4jpp.2
libart_lgpl-2.3.17-4
gjdoc-0.7.7-12.el5
eclipse-ecj-3.2.1-19.el5

Which all looks the same but I have no libgfortran installed.

Jan could you do a quick yum whatrequires libgfortran and see if that turns anything up?

Ticket moved back to ASSIGNED.
Comment 4 Jan Pazdziora 2009-04-06 09:59:31 EDT
The RHEL 5 yum does not seem to have whatrequires. However,

# rpm -q --whatrequires libgfortran
no package requires libgfortran

So it's really weird, nothing seems to need that package yet it seems to be installed on my machine.

You don't have it already installed on the machine when you run ./install.pl, by any chance?
Comment 5 Devan Goodwin 2009-04-06 10:50:12 EDT
Nope not installed before or after install.pl. :(
Comment 6 Jan Pazdziora 2009-04-07 05:20:53 EDT
I've rerun the ./install.pl with debuglevel=9 in yum.conf and here's what I got

--> Processing Dependency: /usr/lib/gcj-4.1.1/libjvm.so for package: java-1.4.2-gcj-compat
Searching pkgSack for dep: /usr/lib/gcj-4.1.1/libjvm.so
Potential match for /usr/lib/gcj-4.1.1/libjvm.so from libgfortran-4.1.2-42.el5.i386
Potential match for /usr/lib/gcj-4.1.1/libjvm.so from libstdc++-devel-4.1.1-52.el5.2.i386
Potential match for /usr/lib/gcj-4.1.1/libjvm.so from policycoreutils-gui-1.33.12-3.el5.i386
Potential match for /usr/lib/gcj-4.1.1/libjvm.so from 1:cups-1.3.7-8.el5.i386
Potential match for /usr/lib/gcj-4.1.1/libjvm.so from gstreamer-plugins-good-devel-0.10.4-4.el5.i386
1:cups-1.3.7-8.el5.i386 is in providing packages but it is already installed, removing.
Running compare_providers() for [<YumAvailablePackageSqlite : libgfortran-4.1.2-42.el5.i386 (0x91c26cc)>, <YumAvailablePacka
geSqlite : policycoreutils-gui-1.33.12-3.el5.i386 (0x8e1a92c)>, <YumAvailablePackageSqlite : libstdc++-devel-4.1.1-52.el5.2.
i386 (0x8f955cc)>, <YumAvailablePackageSqlite : gstreamer-plugins-good-devel-0.10.4-4.el5.i386 (0x91363cc)>]
Best Order: [(<YumAvailablePackageSqlite : libgfortran-4.1.2-42.el5.i386 (0x91c26cc)>, -11), (<YumAvailablePackageSqlite : l
ibstdc++-devel-4.1.1-52.el5.2.i386 (0x8f955cc)>, -15), (<YumAvailablePackageSqlite : policycoreutils-gui-1.33.12-3.el5.i386 
(0x8e1a92c)>, -19), (<YumAvailablePackageSqlite : gstreamer-plugins-good-devel-0.10.4-4.el5.i386 (0x91363cc)>, -28)]
TSINFO: Marking libgfortran-4.1.2-42.el5.i386 as install for java-1.4.2-gcj-compat-1.4.2.0-40jpp.115.i386
java-1.4.2-gcj-compat-1.4.2.0-40jpp.115.i386 requires: /usr/lib/gcj-4.1.1/libjvm.so
--> Processing Dependency: /usr/lib/gcj-4.1.1/libjvm.so for package: java-1.4.2-gcj-compat
Searching pkgSack for dep: /usr/lib/gcj-4.1.1/libjvm.so
Potential match for /usr/lib/gcj-4.1.1/libjvm.so from libgfortran-4.1.2-42.el5.i386
Potential match for /usr/lib/gcj-4.1.1/libjvm.so from libstdc++-devel-4.1.1-52.el5.2.i386
Potential match for /usr/lib/gcj-4.1.1/libjvm.so from policycoreutils-gui-1.33.12-3.el5.i386
Potential match for /usr/lib/gcj-4.1.1/libjvm.so from 1:cups-1.3.7-8.el5.i386
Potential match for /usr/lib/gcj-4.1.1/libjvm.so from gstreamer-plugins-good-devel-0.10.4-4.el5.i386
1:cups-1.3.7-8.el5.i386 is in providing packages but it is already installed, removing.
libgfortran-4.1.2-42.el5.i386 already in ts, skipping this one
java-1.4.2-gcj-compat-1.4.2.0-40jpp.115.i386 requires: /usr/lib/gcj-4.1.1/libjvm.so
--> Processing Dependency: /usr/lib/gcj-4.1.1/libjvm.so for package: java-1.4.2-gcj-compat
Searching pkgSack for dep: /usr/lib/gcj-4.1.1/libjvm.so
Potential match for /usr/lib/gcj-4.1.1/libjvm.so from libgfortran-4.1.2-42.el5.i386
Potential match for /usr/lib/gcj-4.1.1/libjvm.so from libstdc++-devel-4.1.1-52.el5.2.i386
Potential match for /usr/lib/gcj-4.1.1/libjvm.so from policycoreutils-gui-1.33.12-3.el5.i386
Potential match for /usr/lib/gcj-4.1.1/libjvm.so from 1:cups-1.3.7-8.el5.i386
Potential match for /usr/lib/gcj-4.1.1/libjvm.so from gstreamer-plugins-good-devel-0.10.4-4.el5.i386
1:cups-1.3.7-8.el5.i386 is in providing packages but it is already installed, removing.
libgfortran-4.1.2-42.el5.i386 already in ts, skipping this one

So, for some reason, libgfortran-4.1.2-42.el5.i386 is being considered for /usr/lib/gcj-4.1.1/libjvm.so requirement.
Comment 7 Devan Goodwin 2009-04-14 09:19:23 EDT
So a file based requires from java-1.4.2-gcj-compat is leading us to libgfortran in some setups (which we don't yet know how to reproduce). With neither of these packages under our control, I guess we need to make this packages installed checking a little more forgiving?

Jan is there any additional info you can provide about your setup that would cause you to get this suddenly? Are you testing on a customized RHEL install of some kind or just a relatively standard base install?   Any possible differences in channels you're subscribed too?
Comment 8 Devan Goodwin 2009-04-20 09:16:14 EDT
Just looking for any additional info you can provide on why this system is getting different packages to provide what it needs as per above comment. If necessary I will try to get the package checking code to be more forgiving but I'd like to be able to reproduce before I do that.

Thanks.
Comment 9 Jan Pazdziora 2009-04-20 11:10:05 EDT
Nope, I don't really know what is the differentiator for my setup.
Comment 10 Jan Pazdziora 2009-04-28 06:08:46 EDT
Reassigning to self.
Comment 11 Jan Pazdziora 2009-04-29 07:22:45 EDT
With freshly kickstarted RHEL 5.3 and Satellite-5.3.0-RHEL5-re20090424.1 on i386, I was no longer able to reproduce the problem.

Note You need to log in before you can comment on or make changes to this bug.