Bug 489870 - Can't install onto existing lvm-on-mdraid
Can't install onto existing lvm-on-mdraid
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 08:42 EDT by Owen Taylor
Modified: 2009-06-25 11:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 11:41:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Owen Taylor 2009-03-12 08:42:43 EDT
I have a system where the existing partitioning looks something like:

 LogVol00: /
 LogVol01: /home

 VolGroup00: md0

 md0: /dev/sda5 /dev/sdb5 (raid1)

I wanted to install over the system on LogVol00, preserving the data on LogVo01, so I ran the current (March 12) anaconda from a network install.

I chose "custom layout", and when I get to the partioning screen, I see the md device, but the lvm volumes are not visible. "Edit" on the md device show "Original File System Type: Unknown" (probably unrelated - it oddly shows number of spares: -2)

Switching to a terminal and using 'lvm pvs' 'lvm lvs' I see the physical and logical volumes.
Comment 1 David Lehman 2009-03-12 14:21:07 EDT
This is known and is related to udev rules. A fix went into git last night, so it should appear in rawhide on Friday. Please reopen this bug if the issue is not resolved in Friday's rawhide. Thanks for filing a report.
Comment 2 Owen Taylor 2009-03-13 07:50:36 EDT
Behavior with the boot.iso with the date of '13-Mar-2009 05:37' is exactly the same as previously.
Comment 3 David Lehman 2009-03-13 11:11:32 EDT
Right -- the new build of anaconda (11.5.0.29-1) didn't get pulled into rawhide.
Comment 4 Chris Lumens 2009-03-17 10:49:44 EDT
This should be fixed as of today's rawhide, which contains anaconda-11.5.0.31.
Comment 5 Owen Taylor 2009-03-17 19:15:20 EDT
Behavior with anaonda-11.5.0.31 is similar.

One noted difference is that switching to a vt, 'lvm pvs' and 'lvm lvs' show nothing. (md0 doesn't seem to have been started)
Comment 6 David Lehman 2009-03-19 13:28:13 EDT
This should be fixed in today's rawhide (anaconda-11.5.0.33-1).
Comment 7 Bug Zapper 2009-06-09 08:09:09 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.