Bug 489890 - Upgrading autofs5 package turns autofs5 off in chkconfig
Upgrading autofs5 package turns autofs5 off in chkconfig
Status: CLOSED DUPLICATE of bug 471838
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs5 (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ian Kent
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 09:52 EDT by Olivier Fourdan
Modified: 2013-03-03 21:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-12 10:05:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (264 bytes, patch)
2009-03-12 09:52 EDT, Olivier Fourdan
no flags Details | Diff

  None (edit)
Description Olivier Fourdan 2009-03-12 09:52:48 EDT
Created attachment 334927 [details]
Proposed patch

Description of problem:

The spec file for autofs5 does a "chkconfig autofs5 off" in %post.

As a result, upgrading that package prevents autofs5 to be restarted at next reboot.

Version-Release number of selected component (if applicable):

autofs5-5.0.1-0.rc2.88.i386

How reproducible:

100% reproducible

Steps to Reproduce:
1. # rpm -q autofs5
   autofs5-5.0.1-0.rc2.55
2. # chkconfig autofs5 --list
   autofs5         0:off   1:off   2:on    3:on    4:on    5:on    6:off
3. # rpm -U autofs5-5.0.1-0.rc2.88.i386.rpm
4. # chkconfig autofs5 --list
   autofs5         0:off   1:off   2:off   3:off   4:off   5:off   6:off
  
Actual results:

   autofs5         0:off   1:off   2:off   3:off   4:off   5:off   6:off

Expected results:

   autofs5         0:off   1:off   2:on    3:on    4:on    5:on    6:off

Additional info:

Proposed patch attached (trivial). Though I am not sure why autofs5 is turned off by default in %post, maybe that could be a suitable behavior for installation but upgrading should not change the defaults.
Comment 1 Ian Kent 2009-03-12 10:05:35 EDT
Please have a look at bug 471838 and see if that satisfies
your needs.

*** This bug has been marked as a duplicate of bug 471838 ***

Note You need to log in before you can comment on or make changes to this bug.