Bug 489902 - "Help" bubbles for page titles all go to non-existent pages.
"Help" bubbles for page titles all go to non-existent pages.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brad Buckingham
Petr Sklenar
:
Depends On:
Blocks: 456984
  Show dependency treegraph
 
Reported: 2009-03-12 10:17 EDT by Corey Welton
Modified: 2009-09-10 16:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:45:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2009-03-12 10:17:37 EDT
Description of problem:
Click virtually any "?" help bubble icon for a page title.  The accompanying pages don't exist

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090306.2-i386.iso

How reproducible:
Every time.

Steps to Reproduce:
1.  Login; go to "Overview"
2.  click the ",(?)" icon next to the page title ("Overview")
3.  View results
  
Actual results:
404

Expected results:
Contextual help page - or, all of these help links removed.

Additional info:
This seems to be the case for every help bubble I have thus far tried across the system.
Comment 1 Shannon Hughes 2009-03-12 15:42:50 EDT
missing rhn-i18n-guides and rhn-i18n-release-notes
Comment 2 Brad Buckingham 2009-04-27 17:45:31 EDT
master git commit: 11b579172c95178eb8a9cda5d2b42cf907a56d42
vader git commit: 9467e8b977de08200a2a0afe426fe6481ea93d78

Unfortunately, the new rhn-il8n-guides has reorganized quite a bit of the documentation, such that many of the links (after inclusion of the new package) were still broken.  As a result, had to go through the code and manually update the help links in ~150 files, because there was no clear/consistent pattern to the change.  I believe I have caught all of affected pages.  Also, for the modifications, I simply updated the pages to point to the corresponding link from the new docs; therefore, the assumption is that the previous help links were already pointing to the correct location within the documentation.

See the following commit for a listing of the files updated:

http://git.fedorahosted.org/git/?p=spacewalk.git;a=commit;h=11b579172c95178eb8a9cda5d2b42cf907a56d42
Comment 3 Petr Sklenar 2009-05-12 13:54:57 EDT
hello,
I looked at "?"/help in Satellite-5.3.0-RHEL4-re20090507.1 and it seems that some lines in page are somehow underlines which seems strange(like link). Firefox was used.

Is it OK?

you can see:
https://xen95.englab.brq.redhat.com/rhn/help/reference/en-US/s1-sm-systems.jsp#s2-sm-system-overview

there is similar overview on rhn.webqa and that seem ok.
Comment 4 Brad Buckingham 2009-05-13 10:46:51 EDT
Hi Petr,

Good observation.  It looks like the issue is that the docs are using the <a > tag which is typically used for links/bookmarks.  I don't think this was intended.  It may be something that is different in the content that we receive from the documentation team or in the tools that are used to convert that content to jsp.  I'd recommend creating a separate BZ to track that.
Comment 5 Petr Sklenar 2009-05-14 06:38:34 EDT
OK, filled bug 500806

then I found another issues:

I.
see 
Channel
Manage software channels
question-mark at > Software Channel Management(?)

It points to:

https://us-es7600r-01.rhts.bos.redhat.com/rhn/channels/manage/channel-mgmt-Custom_Channel_and_Package_Management.jsp

but its not exists :(

similar help is:

https://us-es7600r-01.rhts.bos.redhat.com/rhn/help/channel-mgmt/en-US/channel-mgmt-Custom_Channel_and_Package_Management-Managed_Software_Channel_Details.jsp

https://us-es7600r-01.rhts.bos.redhat.com/rhn/help/reference/en-US/s1-sm-channels-packages.jsp#s2-sm-channel-manage

-----------------------------------------
II.

There is titles and link to help is missing, like "Activation Keys" but help exists > https://us-es7600r-01.rhts.bos.redhat.com/rhn/help/reference/en-US/s1-sm-systems.jsp#s2-sm-systems-activation-keys
Comment 6 Brad Buckingham 2009-05-14 09:16:35 EDT
If possible, please send me the login information for the above system via email.  I wasn't able to log in to it.

Also, let me make a second pass at the doc links.  Unfortunately, they completely restructured the documentation which broke all of the help links which are scattered throughout the application. I updated ~150 that I had found through command-line code searching; however, it appears that there is a pattern that was not picked up with that.  Perhaps the code is including the links using multiple approaches.

If you want, feel free to move the BZ to FAILS_QA, since I will need to submit more updates.  Also, if you observe any additional broken links, do add them to the BZ.
Comment 7 Brad Buckingham 2009-05-14 11:37:37 EDT
master git commit: c2b6496f082b2761e0da4ffa1dbeac06ca7e5d9e, f9012f4838e079f5d05ad809947df019fe9da1b4
vader git commit: 8a985eff47df38504f924677aaa75d985343a06f, 443933dc7c28f9041addfd43f28d94b6cdb508b8

I fixed the broken link for the Channels->Manage Software Channels.  It looks like that page may have been ported to Java and in doing so, the correct name for the documentation file was added, but the path was incorrect.  As a result, the script did not detect the difference.

I also added a link to the Systems->ActivationKeys page as mentioned in #5.  There are likely help links missing from other pages. I'd recommend that any of those identified be documented in a separate BZ from this one.  This BZ was to ensure that those help links that do exist are still valid with the the new documentation.

Moving bug back to MODIFIED to include the above in next ISO.
Comment 8 Brad Buckingham 2009-05-20 09:20:55 EDT
Mass move to ON_QA.
Comment 9 Petr Sklenar 2009-05-21 07:19:21 EDT
verified;
test:
checked all "(?)" icon next to the page title
PASS

tested system:
x86_64
rhel5U3
Satellite-5.3.0-RHEL5-re20090520.0
Comment 10 Miroslav Suchý 2009-08-13 03:54:41 EDT
verified in stage.
Comment 11 Brandon Perkins 2009-09-10 16:45:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.