Bug 489903 - DeviceError: new lv is too large to fit in free space
DeviceError: new lv is too large to fit in free space
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:89f94c0877e0f06b0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 10:26 EDT by James Laska
Modified: 2013-09-02 02:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 11:42:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (76.93 KB, text/plain)
2009-03-12 10:27 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-03-12 10:26:56 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.28 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 1530, in _addLogVol
    raise DeviceError("new lv is too large to fit in free space")
  File "/usr/lib/anaconda/storage/devices.py", line 1698, in __init__
    self.vg._addLogVol(self)
  File "/usr/lib/anaconda/storage/__init__.py", line 557, in newLV
    return LVMLogicalVolumeDevice(name, vg, *args, **kwargs)
  File "/usr/lib/anaconda/storage/partitioning.py", line 185, in doAutoPartition
    size=size)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 227, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1350, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/usr/lib/anaconda/gui.py", line 1513, in setup_window
    self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 1523, in run
    self.setup_window(runres)
  File "/usr/lib/anaconda/gui.py", line 1270, in run
    self.icw.run (self.runres)
  File "/usr/bin/anaconda", line 1012, in <module>
    anaconda.intf.run(anaconda)
DeviceError: new lv is too large to fit in free space
Comment 1 James Laska 2009-03-12 10:27:01 EDT
Created attachment 334932 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-03-12 14:24:57 EDT
Looks like this should be fixed in Joel's dev vs. devs typo fix from earlier today.  It's worth giving the next rawhide a try.
Comment 3 Bug Zapper 2009-06-09 08:09:32 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.