Bug 490003 - rhn-upgrade docs needs to be updated to mention that pre 3.6 satellites needs to upgraded to 3.6 level before upgrading to 5.2
rhn-upgrade docs needs to be updated to mention that pre 3.6 satellites needs...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
520
All Linux
low Severity medium
: ---
: ---
Assigned To: Milan Zázrivec
Jeff Browning
:
Depends On:
Blocks: 456986
  Show dependency treegraph
 
Reported: 2009-03-12 16:24 EDT by Preethi Thomas
Modified: 2009-08-27 13:38 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-27 13:38:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2009-03-12 16:24:10 EDT
Description of problem:

rhn-upgrade docs needs to be updated to mention that pre 3.6 satellites needs to upgraded to 3.6 level before upgrading to 5.2

as per my conversation with michael I was told that sat 3.6 is the oldest version supported in 5.2.0 upgrade.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install the rhn-upgrade-5.2.0-28.el4
2. cat  rhn-satellite-5-upgrade-scenario-1a.txt and rhn-satellite-5-upgrade-scenario-1b.txt
3. schema upgrade has steps starting at schema version 2.6
  
Actual results:
 schema upgrade has steps starting at schema version 2.6

Expected results:

if the oldest satellite level you can upgrade to 5.2 is 3.6 then these steps up until 3.6 schema upgrade needs to be deleted from the doc .
Additional info:
Comment 2 Preethi Thomas 2009-03-18 16:17:33 EDT
here is the irc log

Feb 26 10:20:49 michael sat 3.2 contains oracle 9.2.0.3; the older oracle which can be upgraded to 10g is 9.2.0.4....
Comment 4 Brandon Perkins 2009-03-19 10:56:42 EDT
Based on Comment #3 From  Michael Mráka, this makes sense now, so approved.
Comment 5 Milan Zázrivec 2009-04-16 11:07:35 EDT
satellite.git SATELLITE-5.3: 528fe5d94777ffe436cd17ec3ca5c74464a46c3b

Upgrade documentation no longer lists the particular steps for schema
upgrade for every single schema version. This job is being done automatically
now by spacewalk-schema-upgrade script (as mentioned in documentation).

With 5.3.0, we support upgrades from schemas ver. 3.1.5 and newer (which
is mentioned in README document). About the embedded database upgrade:
I made a note in README document telling that to be able to upgrade
embedded database to 10g, customer needs to have at least version 9.2.0.4
of 9i database (which came with Satellite 3.6). If customer is running
9i ver. 9.2.0.3 or older, he needs to upgrade his Satellite to any version
between 3.6 and 5.1 first (also mentioned in README).
Comment 6 Milan Zázrivec 2009-04-23 06:26:00 EDT
rhn-upgrade-5.3.0.7-1
Comment 7 Jeff Browning 2009-06-16 00:42:22 EDT
Verified
Comment 8 Miroslav Suchý 2009-08-25 09:23:13 EDT
/etc/sysconfig/rhn/satellite-upgrade/README contains text from #5
verified in stage on xen5
Comment 9 Brandon Perkins 2009-08-27 13:38:16 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1235.html

Note You need to log in before you can comment on or make changes to this bug.