Bug 490042 - RuntimeError: can't find partition dm-01 in device tree
RuntimeError: can't find partition dm-01 in device tree
Status: CLOSED DUPLICATE of bug 489427
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 18:38 EDT by Luke Macken
Modified: 2016-09-19 22:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-13 09:57:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full anaconda debug output (36.43 KB, text/plain)
2009-03-12 18:38 EDT, Luke Macken
no flags Details

  None (edit)
Description Luke Macken 2009-03-12 18:38:43 EDT
Created attachment 335023 [details]
full anaconda debug output

Description of problem:

anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 815, in populate
    " tree" % partName)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1339, in getScreen
    self.populate(initial = 1)
  File "/usr/lib/anaconda/gui.py", line 1401, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1318, in nextClicked
    self.setScreen ()
RuntimeError: can't find partition dm-01 in device tree


Version-Release number of selected component (if applicable):

http://katzj.fedorapeople.org/rawhide-i686-20090312.0.iso


Steps to Reproduce:
1. Check the box to review partition layout
2. Click next.
3. *boom*
Comment 1 Hans de Goede 2009-03-13 04:56:49 EDT
Ok,

So the problem is that *before* we start scanning disks and activating stuff like existing lvm's / dmraid sets, you already have dm-0 and dm-1 device mapper devices.

Do you know what they are / where they've come from ? Usually all the device
mapper devices are made by us, so we know what they are. Now we are somehow misidentifying them as disks.
Comment 2 Hans de Goede 2009-03-13 08:27:34 EDT
Luke,

The rawhide image you are referring to, that wouldn't by any chance be a livecd
image would it ?

I think this is caused by us not recognizing LV's as LV's on livecd's, which
would mean this is a dup of 489427.
Comment 3 Chris Lumens 2009-03-13 09:57:51 EDT
No sooner had I put this bug in needinfo than I found another one with the same problem.  Duping...

*** This bug has been marked as a duplicate of bug 489427 ***
Comment 4 Luke Macken 2009-03-13 10:18:34 EDT
(In reply to comment #2)
> Luke,
> 
> The rawhide image you are referring to, that wouldn't by any chance be a livecd
> image would it ?

Yes, this was on a livecd.

Note You need to log in before you can comment on or make changes to this bug.