Bug 490044 - 'NoDevice' object has no attribute 'teardownFormat'
'NoDevice' object has no attribute 'teardownFormat'
Status: CLOSED DUPLICATE of bug 489915
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 18:45 EDT by Luke Macken
Modified: 2016-09-19 22:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-12 22:35:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Macken 2009-03-12 18:45:03 EDT
Description of problem:
I got this traceback when firing up the 'liveinst' a second time to try and do an install.

Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/__init__.py", line 1466, in umountFilesystems
    device.teardownFormat() 
  File "/usr/lib/anaconda/livecd.py", line 162, in doPreInstall
    swapoff = False)
  File "/usr/lib/anaconda/backend.py", line 279, in doPreInstall
    anaconda.backend.doPreInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1338, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'NoDevice' object has no attribute 'teardownFormat'

Version-Release number of selected component (if applicable):

http://katzj.fedorapeople.org/rawhide-i686-20090312.0.iso in kvm
Comment 1 David Lehman 2009-03-12 22:35:45 EDT

*** This bug has been marked as a duplicate of bug 489915 ***

Note You need to log in before you can comment on or make changes to this bug.