Bug 490098 - IPC race condition allows multiple ipc threads within service engine at same time
IPC race condition allows multiple ipc threads within service engine at same ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais (Show other bugs)
5.4
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Steven Dake
Cluster QE
: ZStream
Depends On:
Blocks: 491391
  Show dependency treegraph
 
Reported: 2009-03-13 05:15 EDT by Steven Dake
Modified: 2016-04-26 09:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:29:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Dake 2009-03-13 05:15:50 EDT
Description of problem:
The IPC system allows multiple ipc dispatch threads to enter a service engine (cpg) at the same time.  Since service engines are not reentrant, they must be protected from multiple threads of execution.

Results in segfaults.

Version-Release number of selected component (if applicable):
openais-0.80.5-4

How reproducible:
100%

Steps to Reproduce:
1. run aisexec single node.  Modify testckpt to exit(0) after first ckptClose.  Segfault.
2.  other failures have been observed.
3.
  
Actual results:
segfault.

Expected results:
shouldn't segfault.

Additional info:
Comment 1 Steven Dake 2009-03-13 05:16:50 EDT
patch available.
Comment 6 errata-xmlrpc 2009-09-02 07:29:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1366.html

Note You need to log in before you can comment on or make changes to this bug.