Bug 490099 - Checkpoint service incorrectly calculates reference counts on checkpoints from leaving node
Checkpoint service incorrectly calculates reference counts on checkpoints fro...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais (Show other bugs)
5.3
All Linux
urgent Severity medium
: rc
: ---
Assigned To: Steven Dake
Cluster QE
: ZStream
Depends On:
Blocks: 491395
  Show dependency treegraph
 
Reported: 2009-03-13 05:25 EDT by Steven Dake
Modified: 2016-04-26 11:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:29:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Dake 2009-03-13 05:25:26 EDT
Description of problem:
Nodes that depart the cluster are incorrectly tracked in the refcount.  This means the checkpoint duration timer is never fired because reference counts are always > 1.

Version-Release number of selected component (if applicable):
openai-0.80.3-22 and below

How reproducible:
100%

Steps to Reproduce:
1.start two nodes, open checkpoint on each with test app, sleep in app continually
2.kill second node
3.white box instrumentation shows refcount at 2, when it should be at 1
  
Actual results:
refcount is higher then number of checkpoint opens in system and checkpoint is never garbage collected when all checkpoint opens are closed.

Expected results:
refcount should match number of checkpoint opens

Additional info:
Comment 1 Steven Dake 2009-03-13 05:25:49 EDT
patch available.
Comment 2 Irina Boverman 2009-03-20 14:29:48 EDT
please add this bug to the rhel 5.3.x errata currently in testing.
Comment 6 errata-xmlrpc 2009-09-02 07:29:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1366.html

Note You need to log in before you can comment on or make changes to this bug.