Bug 490111 - no architecture in the package list and ISE on package details page
no architecture in the package list and ISE on package details page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Pradeep Kilambi
Jan Hutař
: Reopened
Depends On:
Blocks: 457071 471789
  Show dependency treegraph
 
Reported: 2009-03-13 07:01 EDT by Jan Hutař
Modified: 2009-09-10 14:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:44:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/tomcat5/catalina.out (7.94 KB, application/octet-stream)
2009-03-13 07:07 EDT, Jan Hutař
no flags Details

  None (edit)
Description Jan Hutař 2009-03-13 07:01:25 EDT
Description of problem:
I do not see package archs in the Software > Packages > List / Remove and when I try to see package's details, I'm getting ISE.


Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090306.2-x86_64


How reproducible:
always


Steps to Reproduce:
1. See list in Software > Packages > List / Remove
   -> in the arch column there is only "not specified"
2. See details of some package in that list
   -> ISE


Actual results:
"not specified" architecture and ISE on package details page


Expected results:
propper architecture and package details


Additional info:
If this is a bug, could we get it to the list of the bugs blocking QA?
Comment 1 Jan Hutař 2009-03-13 07:07:20 EDT
Created attachment 335071 [details]
/var/log/tomcat5/catalina.out

This appears in the /var/log/tomcat5/catalina.out when I display package details page at:

https://pipa02.englab.brq.redhat.com/rhn/software/packages/Details.do?sid=1000010003&id_combo=336|170|
Comment 2 Jan Hutař 2009-03-16 06:07:06 EDT
I do not see this after I have re-synced from webqa - this was probably caused by the fact, that the original dump I have used was from Satellite 520. But 530 should handle this somehow IMO.
Comment 3 Brandon Perkins 2009-03-17 12:15:40 EDT
Cliff and I think there is a bug here, but we're not sure if its ISS or Multi-Arch, so double-trackering it.  Developers please see if you can reproduce this both from a 5.2 dump and without and see if that is the variable, or if something in Multi-arch is odd.
Comment 4 Brad Buckingham 2009-03-17 12:33:32 EDT
I was able to reproduce this issue.  I basically synced a channel from the 5.2 internal dump to the server, registered a system that used that channel, performed System->Software->List/Remove to access the system's package list.

Once there, it is observed that the Architecture is listed as "not specified".  If attempt to select a package from the list, an ISE is generated.  In this case selecting a package takes the user to a url like: 

https://<server>.com/rhn/software/packages/Details.do?sid=1000010119&id_combo=53|4120|

Observe that the 'arch' is missing from the id_combo.

I have not determined if this is an issue with the sync itself.  Perhaps Pradeep can comment on that part.

From the server-side; however, it may be possible to have the logic support both queries that include the arch in the id_combo as well as those that do not; however, need to investigate further.

For reference, if you want to take a peak at the behavior.  Take a look at fjs-0-03 with client dhcp77-182.
Comment 7 Jan Hutař 2009-06-17 06:16:37 EDT
Have not seen this on Satellite-5.3.0-RHEL5-re20090612.0-x86_64
Comment 8 Miroslav Suchý 2009-08-10 10:01:00 EDT
verified in stage.
Comment 9 Brandon Perkins 2009-09-10 14:44:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.