Bug 490158 - libxenstore.so leaks memory on every @domainIntroduced event
libxenstore.so leaks memory on every @domainIntroduced event
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Michal Novotny
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-13 11:53 EDT by Daniel Berrange
Modified: 2014-02-02 17:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 06:11:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug fix (644 bytes, patch)
2009-03-16 04:55 EDT, Michal Novotny
no flags Details | Diff

  None (edit)
Description Daniel Berrange 2009-03-13 11:53:20 EDT
Description of problem:
There is a bug in libxenstore.so which causes memory to leak on every @domainIntroduced event. Latest libvirt uses xenstore events for monitoring, so this will cause a leak in libvirtd daemon

Trivial fix is upstream

changeset:   18469:346c073ed6a4
user:        Keir Fraser <keir.fraser@citrix.com>
date:        Thu Sep 11 18:00:06 2008 +0100
files:       tools/xenstore/xs.c
description:
xenstore: Fix a memory leak in 'xs_is_domain_introduced'.

Signed-off-by: Konrad Rzeszutek <konrad@virtualiron.com>



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Michal Novotny 2009-03-16 04:55:31 EDT
Created attachment 335322 [details]
Bug fix

Here is just a simple bug fix for this issue not to memory leak here. It's working fine. There was just a memory allocation issue like described both here and in the upstream.
Comment 2 Jiri Denemark 2009-03-20 09:52:11 EDT
Fix built into xen-3.0.3-83.el5
Comment 4 Yewei Shao 2009-07-24 06:57:40 EDT
I want to verify this bug because of the errata testing, but I need more steps or need some advice for this bug verification since this bug do not contains any steps, thanks.
Comment 6 Yewei Shao 2009-07-29 03:00:12 EDT
Verified in xen-3.0.3-91.el5
Comment 8 errata-xmlrpc 2009-09-02 06:11:49 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1328.html

Note You need to log in before you can comment on or make changes to this bug.