Bug 49023 - relocation fails, possibly bad string operation
Summary: relocation fails, possibly bad string operation
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-13 02:42 UTC by Brian Gunney
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-13 08:59:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec file (528 bytes, text/plain)
2001-07-13 02:43 UTC, Brian Gunney
no flags Details

Description Brian Gunney 2001-07-13 02:42:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Using --relocate /usr=/usr/local leads to false error

How reproducible:
Always

Steps to Reproduce:
1. Build package using testreloc.spec (attached)
2. Install rpm as follows:
rpm -ivh --relocate /usr=/usr/local testreloc-0.1-1.i386.rpm
3.
	

Actual Results:  rockies:~/brian/rpm/rpms/i386>14 rpm -ivh --relocate
/usr=/usr/local testreloc-0.1-1.i386.rpm 
Preparing...                ###########################################
[100%]
file /usrlocal from install of testreloc-0.1-1 conflicts with file from
package filesystem-2.0.7-1


Expected Results:  Package installed with files relocated to /usr/local

Additional info:
Note missing "/" between "usr" and "local".

Comment 1 Brian Gunney 2001-07-13 02:43:30 UTC
Created attachment 23468 [details]
spec file

Comment 2 Michael Schwendt 2001-07-13 08:59:26 UTC
Duplicate of bug #46890.

Comment 3 Jeff Johnson 2001-07-13 12:35:13 UTC
Try rpm-4.0.3-0.57 from
	ftp://ftp.rpm.org/pub/rpm/test-4.0.3
Relocations were broken in rpm-4.0.2, fixed in rpm-4.0.3-0.6


Note You need to log in before you can comment on or make changes to this bug.