Bug 490256 - gnome-volume-control cannot control/mute volume of microphone
gnome-volume-control cannot control/mute volume of microphone
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
: 471277 486026 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-14 06:26 EDT by Eddie Lania
Modified: 2009-10-21 15:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 15:04:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eddie Lania 2009-03-14 06:26:05 EDT
Description of problem: gnome-volume-control cannot control/mute volume of microphone


Version-Release number of selected component (if applicable):

[root@p3000fedora ~]# rpm -qa |grep -i alsa
python-alsaaudio-0.4-1.fc10.i386
alsa-plugins-upmix-1.0.18-2.fc10.i386
alsa-plugins-pulseaudio-1.0.18-2.fc10.i386
alsa-lib-devel-1.0.19-2.fc10.i386
alsa-utils-1.0.19-2.fc10.i386
alsa-lib-1.0.19-2.fc10.i386
[root@p3000fedora ~]# rpm -qa |grep -i pulse
pulseaudio-utils-0.9.14-1.fc10.i386
pulseaudio-libs-0.9.14-1.fc10.i386
pulseaudio-module-gconf-0.9.14-1.fc10.i386
alsa-plugins-pulseaudio-1.0.18-2.fc10.i386
projectM-pulseaudio-1.2.0-3.fc10.i386
pulseaudio-core-libs-0.9.14-1.fc10.i386
pulseaudio-module-jack-0.9.14-1.fc10.i386
pulseaudio-libs-zeroconf-0.9.14-1.fc10.i386
xine-lib-pulseaudio-1.1.16.2-3.fc10.i386
wine-pulseaudio-1.1.15-1.fc10.i386
pulseaudio-esound-compat-0.9.14-1.fc10.i386
pulseaudio-module-zeroconf-0.9.14-1.fc10.i386
pulseaudio-0.9.14-1.fc10.i386
pulseaudio-libs-glib2-0.9.14-1.fc10.i386
akode-pulseaudio-2.0.2-5.fc9.i386
pulseaudio-module-x11-0.9.14-1.fc10.i386



How reproducible:


Steps to Reproduce:
1. Connect Microphone
2. Try to mute/unmute
3. Try to slide volume up/down
  
Actual results:
Not able to control volume of microphone. I cannot mute the microphone or change it's volume level (the microphone boost options work fine although). I can switch to mic2 using the microphone switch but then the microphone is completely disabled.


Expected results:
Should be able to control the microphone's volume.


Additional info:
Comment 1 Lennart Poettering 2009-03-19 07:12:34 EDT
Sounds like a mixer initialization issue to me.
Comment 2 Eddie Lania 2009-03-21 07:39:54 EDT
This is strange:

I experimented with the different playback channels and now it suddenly works again.

What I did: I enabled all playback channels in the preferences and started turning them on- and off.

Once I got to the "AC97" channel all other channels were working as aspected again.
Comment 3 Bastien Nocera 2009-09-16 14:38:18 EDT
*** Bug 486026 has been marked as a duplicate of this bug. ***
Comment 4 Bastien Nocera 2009-09-16 14:38:24 EDT
*** Bug 471277 has been marked as a duplicate of this bug. ***
Comment 5 Eddie Lania 2009-10-11 12:39:01 EDT
I do not really have a problem with this issue anymore but I am the reporter of this bug. And there are still some people CC'ed to it. Can I savely remove myself from it?
close bug?

Note You need to log in before you can comment on or make changes to this bug.