Bug 490260 - After install xenpv-win,the RedHat PV NIC Driver PNP id is not correct.
After install xenpv-win,the RedHat PV NIC Driver PNP id is not correct.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xenpv-win (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: ashok
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-14 07:18 EDT by koka xiong
Modified: 2010-10-07 12:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 03:33:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the PNP of virtIO (55.77 KB, image/png)
2009-03-14 07:56 EDT, koka xiong
no flags Details
the PNP of Redhat NIC (58.83 KB, image/png)
2009-03-14 07:57 EDT, koka xiong
no flags Details

  None (edit)
Description koka xiong 2009-03-14 07:18:00 EDT
Description of problem:
After install xenpv-win,use everest tool to look at the hardware address of RedHat PV NIC Driver,the address is not correct.

Version-Release number of selected component (if applicable):
xenpv-win-32-bit-1.0.0-1.el5.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1.Install the xenpv-win-32-bit according to the installation manual
2.Look at the hardware address of RedHat PV NIC Driver with everest or other tools.

  
Actual results:
The hardware id is SCSI\Net____RHEL____________NIC0001

Expected results:
The hardware is should be VEN  &DEV   &SUBSYS  &REV

Additional info:
Comment 1 koka xiong 2009-03-14 07:26:15 EDT
Redhat VirtIO NIC has hardware id:PCI\VEN_1AF4&DEV_1000&SUBSYS_00011AF4&REV_00
Comment 2 koka xiong 2009-03-14 07:56:15 EDT
Created attachment 335198 [details]
the PNP of virtIO
Comment 3 koka xiong 2009-03-14 07:57:38 EDT
Created attachment 335199 [details]
the PNP of Redhat NIC
Comment 4 ashok 2009-03-31 06:14:38 EDT
http://www.wd-3.com/archive/InfFiles.htm
The above link gives a nice description on INF files.
The PnP ID is defined in the INF file. Windows Installer Reads this INF file and installs the driver according to the rules defined in the file.

According to the above tutorial link, PnP ID can be a Hardware ID or Compatible ID. 
The ID here is a Compatible ID.
Comment 5 ashok 2009-04-07 02:12:27 EDT
PnP ID is correct, is there any other repercussion which stops certification?
Comment 6 koka xiong 2009-04-17 03:05:24 EDT
Hi, ashok,I have retested again with WLK 1.2 about oem0.inf and oem1.inf.
After applying filter,they can pass Run INFTest against a single INF,Plug and Play Driver Test,Device Path Exerciser.
You are right "According to the above tutorial link, PnP ID can be a Hardware ID or Compatible ID. The ID here is a Compatible ID."

So it is not a bug.
Comment 7 ashok 2009-04-17 03:17:40 EDT
Thanks, for re testing, and updates.

as per C#6 it can be closed.
Comment 8 Lawrence Lim 2009-04-17 03:33:49 EDT
Thanks for the confirmation. Resolving as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.