Bug 490268 - Kernel oops when dvb_net virtual network device is removed
Kernel oops when dvb_net virtual network device is removed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Mauro Carvalho Chehab
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-14 09:55 EDT by Ang Way Chuang
Modified: 2013-07-04 18:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-09 01:27:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel oops message from syslog using 2.6.28.7 stock kernel (3.47 KB, text/plain)
2009-03-14 09:55 EDT, Ang Way Chuang
no flags Details
kernel oops message from syslog using rawhide kernel just before the system hang up (22.54 KB, text/plain)
2009-03-14 09:56 EDT, Ang Way Chuang
no flags Details
kernel oops after dvb_net_feed_start: BUG 972 (35.01 KB, text/plain)
2009-03-18 04:21 EDT, Ang Way Chuang
no flags Details

  None (edit)
Description Ang Way Chuang 2009-03-14 09:55:22 EDT
Created attachment 335207 [details]
kernel oops message from syslog using 2.6.28.7 stock kernel 

Description of problem:
Kernel will oop when dvbnet virtual network device is used after some time. 

Version-Release number of selected component (if applicable):
Rawhide kernel 2.6.29-0.124.rc5.fc10.i586 and stock 2.6.28.7 kernel on Fedora 10

How reproducible:
Occasionally

Steps to Reproduce:
1. Create DVB net device using ULE decapsulation
2. Let it run for some time
3. Then shutdown the DVB net device and remove the DVB net device.
  
Actual results:
Kernel oops, then the system hang up.

Expected results:
Kernel should not oops

Additional info:
Comment 1 Ang Way Chuang 2009-03-14 09:56:44 EDT
Created attachment 335208 [details]
kernel oops message from syslog using rawhide kernel just before the system hang up
Comment 2 Ang Way Chuang 2009-03-18 04:19:23 EDT
I just noticed another kernel oops. Whenever dvb_net_feed_start complains a BUG, then a removal of dvbnet virtual interface will produce the Oops. Attached is the dmesg output from the latest oops.
Comment 3 Ang Way Chuang 2009-03-18 04:21:41 EDT
Created attachment 335667 [details]
kernel oops after dvb_net_feed_start: BUG 972
Comment 4 Mauro Carvalho Chehab 2009-03-28 08:57:58 EDT
There were one recent update at dvb-net, caused by this -git changeset:
   fb875333c80942455551f690f306a899ceeee5df

This moves the dvb-net to an updated net API.

Maybe this is causing some regression. I've reverted this changeset at rawhide cvs. Let's see if this will solve the issue.

It will be available soon (probably on Monday) as a rpm (kernel-2.6.29-17.fc11.rpm or later).

Please test after having it available.
Comment 5 Ang Way Chuang 2009-04-01 23:24:03 EDT
Thanks, Mauro. I've tested using 2.6.29-21.fc11.i686.PAE. I couldn't reproduce the problem anymore. Thus I assume it should have fixed the problem unless the problem occurs again.

Note You need to log in before you can comment on or make changes to this bug.