Bug 490292 - TB3518121c rpcServer.py:168:getServer:SSLCertificateFileNotFound: ERROR: can not find RHNS CA file: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
TB3518121c rpcServer.py:168:getServer:SSLCertificateFileNotFound: ERROR: can ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.3
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: James Antill
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-14 17:28 EDT by jvenuto
Modified: 2013-03-12 16:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 16:29:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SSL Certificate File Not Found (2.20 KB, text/plain)
2009-04-26 11:49 EDT, Rich Harrison
no flags Details

  None (edit)
Description jvenuto 2009-03-14 17:28:48 EDT
Description of problem:

Exception upon software upgrade from console

Component: can not find RHNS CA file: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
Summary: TB3518121c rpcServer.py:168:getServer:SSLCertificateFileNotFound: ERROR: can not find RHNS CA file: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 490, in ?
    main()
  File "/usr/sbin/pirut", line 483, in main
    pm = PackageManager(options.config, options.onlyrepo)
  File "/usr/sbin/pirut", line 67, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 137, in __init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 139, in doConfigSetup
    errorlevel=errorlevel)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 205, in _getConfig
    self.plugins.run('init')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 176, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/rhnplugin.py", line 110, in init_hook
    login_info = up2dateAuth.getLoginInfo()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 217, in getLoginInfo
    login()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 168, in login
    server = rhnserver.RhnServer()
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 149, in __init__
    self._server = rpcServer.getServer()
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 168, in getServer
    raise up2dateErrors.SSLCertificateFileNotFound(msg)
SSLCertificateFileNotFound: ERROR: can not find RHNS CA file: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT

Local variables in innermost frame:
lang: en_US
rhns_ca_cert: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
log: <up2date_client.up2dateLog.Log instance at 0x11e5b2d8>
proxyUser: None
cfg: <up2date_client.config.Config instance at 0x11e58f38>
ca: ['/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT']
rhns_ca_certs: ['/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT']
proxyPassword: None
proxyHost: None
s: <RetryServer for rhn.redhat.com/XMLRPC>
refreshCallback: None
serverUrls: ['https://rhn.redhat.com/XMLRPC']
env: LANG
msg: ERROR: can not find RHNS CA file: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
serverList: <up2date_client.rpcServer.ServerList instance at 0x11b76c20>

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Applications
2.Add/Remove Software
3.
  
Actual results:

Exception - no updates

Expected results:

Download software updates


Additional info:
Comment 1 Steve Durbin 2009-04-24 09:00:26 EDT
Same error here with yum from command line. New install of RHEL.
Comment 2 Steve Durbin 2009-04-24 09:27:46 EDT
FIX-FIX-FIX

This bug is simply because rhn_register has not been run. Running this fixes problem at once.
Comment 3 Rich Harrison 2009-04-26 11:49:55 EDT
Created attachment 341360 [details]
SSL Certificate File Not Found
Comment 4 James Antill 2013-03-12 16:29:23 EDT
This request was evaluated by Red Hat Engineering for inclusion in a Red 
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat 
Enterprise Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in 
response to customer and partner requirements, Red Hat takes a 
conservative approach when evaluating enhancements for inclusion in 
maintenance updates for currently deployed products. The primary 
objectives of update releases are to enable new hardware platform 
support and to resolve critical defects.

Note You need to log in before you can comment on or make changes to this bug.