Bug 490348 - xine-check does not find plugins
xine-check does not find plugins
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xine-lib (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-15 12:21 EDT by udo
Modified: 2009-03-15 13:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-15 13:51:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description udo 2009-03-15 12:21:43 EDT
Description of problem:
See http://bugs.xine-project.org/show_bug.cgi?id=227

xine-check mentions on my x86_64 box:

[OUCH!!] no plugin directory (/usr/lib/xine/plugins)
         The plugin-directory doesn't exist. xine-config claims that there
         is a plugin directory at /usr/lib/xine/plugins.
         However, there is no such directory.
         You probably need to reinstall xine-lib.
         press <enter> to continue...

But `ls -l /usr/lib64/xine/plugins/1.25/` *does* show my plugins and xine works
quite OK...

ALSO, onn my i386 VIA EN12000 system I get:

[ good ] plugin directory /usr/lib/xine/plugins exists.
[OUCH!!] There are no input plugins.
         xine needs at least one input plugin, but none is installed.
         You should probably reinstall xine-lib...
         press <enter> to continue...

[OUCH!!] There are no demux plugins.
         xine needs at least one demux plugin, but none is installed.
         You should probably reinstall xine-lib...
         press <enter> to continue...

[OUCH!!] There are no decoder plugins.
         xine needs at least one decoder plugin, but none is installed.
         You should probably reinstall xine-lib...
         press <enter> to continue...

[OUCH!!] There are no video_out plugins.
         xine needs at least one video_out plugin, but none is installed.
         You should probably reinstall xine-lib...
         press <enter> to continue...

[OUCH!!] There are no audio_out plugins.
         xine needs at least one audio_out plugin, but none is installed.
         You should probably reinstall xine-lib...
         press <enter> to continue...

But:

# ls  /usr/lib/xine/plugins/1.25/
mime.types                     xineplug_dmx_mpeg_elem.so
post                           xineplug_dmx_mpeg_pes.so
vidix                          xineplug_dmx_mpeg.so
xineplug_ao_out_alsa.so        xineplug_dmx_mpeg_ts.so
xineplug_ao_out_file.so        xineplug_dmx_nsv.so
xineplug_ao_out_none.so        xineplug_dmx_ogg.so
xineplug_ao_out_oss.so         xineplug_dmx_pva.so
(etc)

Version-Release number of selected component (if applicable):
1.1.16.2-1 or -3

How reproducible:
xine-check

Steps to Reproduce:
1. xine-check
2. [enter], [enter] etc
3.
  
Actual results: No plugins found


Expected results: Plugins found


Additional info:
Comment 1 Rex Dieter 2009-03-15 13:51:07 EDT
xine-lib != xine

closing->notabug

(ie, xine's xine-check is bogus and wrong, and xine isn't shipped by fedora).

Note You need to log in before you can comment on or make changes to this bug.