Bug 490382 - FC10 fails to suspend
FC10 fails to suspend
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-15 19:15 EDT by Hiren Joshi
Modified: 2009-04-23 12:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 12:24:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hiren Joshi 2009-03-15 19:15:39 EDT
Description of problem:
Useing gnome, pm-suspend or apcitools -s, the laptop fails to suspend. The memory bit seems ok but it just does not power down, leaving the screen to displaying the console. After that it just hangs.

Steps to Reproduce:
1. Suspend, anywhich way.
2.
3.
  
Actual results:
Hangs

Expected results:
Suspends.

Additional info:
Hibernate has the same effect.

Will happily attach logs.....
Comment 1 Hiren Joshi 2009-03-16 19:43:11 EDT
Kernel: 2.6.27.19-170.2.35.fc10.i686

Log from pm-suspend:
Initial commandline parameters: --quirk-vbemode-restore
--quirk-vbe-post
Mon Mar 16 23:33:57 GMT 2009: Running hooks for suspend.
/usr/lib/pm-utils/sleep.d/00auto-quirk suspend suspend: success.
/usr/lib/pm-utils/sleep.d/00logging suspend suspend: Linux Joshtop 2.6.27.19-170.2.35.fc10.i686 #1 SMP Mon Feb 23 13:21:22 EST 2009 
i686 i686 i386 GNU/Linux
Module                  Size  Used by
michael_mic             6272  2 
arc4                    5760  2 
ecb                     6528  2 
ieee80211_crypt_tkip    11904  1 
aes_i586               11648  1 
crypto_blkcipher       18052  1 ecb
aes_generic            31144  1 aes_i586
ieee80211_crypt_ccmp     8704  1 
fuse                   49436  2 
rfcomm                 33808  4 
fglrx                2044772  22 
bridge                 43668  0 
stp                     6148  1 bridge
bnep                   14848  2 
sco                    12932  2 
l2cap                  21504  16 rfcomm,bnep
irnet                  21916  0 
ppp_generic            23324  1 irnet
slhc                    8704  1 ppp_generic
irtty_sir               8320  0 
sir_dev                14212  1 irtty_sir
ircomm_tty             21896  0 
ircomm                 13316  1 ircomm_tty
autofs4                21124  2 
sunrpc                156052  3 
nf_conntrack_ipv6      15864  1 
ip6t_ipv6header         6016  2 
ip6t_REJECT             7296  2 
ip6table_filter         6400  1 
ip6_tables             14736  2 ip6t_ipv6header,ip6table_filter
ipv6                  230388  27 nf_conntrack_ipv6,ip6t_REJECT
cpufreq_ondemand        9996  1 
acpi_cpufreq           12172  0 
dm_multipath           17164  0 
uinput                 10624  0 
snd_intel8x0           30620  4 
snd_usb_audio          77696  0 
snd_usb_lib            17536  1 snd_usb_audio
snd_rawmidi            22528  1 snd_usb_lib
snd_hwdep              10500  1 snd_usb_audio
snd_intel8x0m          16780  1 
snd_ac97_codec         95268  2 snd_intel8x0,snd_intel8x0m
ac97_bus                5504  1 snd_ac97_codec
snd_seq_dummy           6660  0 
snd_seq_oss            30364  0 
snd_seq_midi_event      9600  1 snd_seq_oss
snd_seq                48576  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         10124  4 snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            42496  0 
snd_mixer_oss          16896  3 snd_pcm_oss
snd_pcm                65924  5 snd_intel8x0,snd_usb_audio,snd_intel8x0m,snd_ac97_codec,snd_pcm_oss
snd_timer              22024  2 snd_seq,snd_pcm
snd                    50616  21 snd_intel8x0,snd_usb_audio,snd_usb_lib,snd_rawmidi,snd_hwdep,snd_intel8x0m,snd_ac97_codec,snd_seq_d
ummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
tg3                   107268  0 
soundcore               9416  3 snd
snd_page_alloc         11016  3 snd_intel8x0,snd_intel8x0m,snd_pcm
iTCO_wdt               13732  0 
iTCO_vendor_support     6916  1 iTCO_wdt
libphy                 18560  1 tg3
i2c_i801               12048  0 
ipw2200               126280  0 
pcspkr                  6272  0 
ieee80211              27464  1 ipw2200
ieee80211_crypt         8324  3 ieee80211_crypt_tkip,ieee80211_crypt_ccmp,ieee80211
i2c_core               21396  1 i2c_i801
btusb                  14360  3 
ppdev                  10372  0 
yenta_socket           24972  1 
rsrc_nonstatic         13568  1 yenta_socket
bluetooth              48608  11 rfcomm,bnep,sco,l2cap,btusb
joydev                 12736  0 
floppy                 51988  0 
parport_pc             25620  0 
thinkpad_acpi          53968  0 
parport                31956  2 ppdev,parport_pc
rfkill                 11160  2 thinkpad_acpi
hwmon                   6300  1 thinkpad_acpi
nsc_ircc               17808  0 
irda                   95240  5 irnet,sir_dev,ircomm_tty,ircomm,nsc_ircc
crc_ccitt               5760  1 irda
video                  20500  0 
output                  6528  1 video
ata_generic             8452  0 
pata_acpi               7680  0 
             total       used       free     shared    buffers     cached
Mem:       2073076     850052    1223024          0      24508     561532
-/+ buffers/cache:     264012    1809064
Swap:      2031608          0    2031608
success.
/usr/lib/pm-utils/sleep.d/00powersave suspend suspend: success.
/usr/lib/pm-utils/sleep.d/01grub suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend: success.
/usr/lib/pm-utils/sleep.d/50ntpd suspend suspend: Shutting down ntpd: [  OK  ]
success.
/usr/lib/pm-utils/sleep.d/55NetworkManager suspend suspend: success.
/usr/lib/pm-utils/sleep.d/55battery suspend suspend: success.
/usr/lib/pm-utils/sleep.d/65alsa suspend suspend: success.
/usr/lib/pm-utils/sleep.d/75modules suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/90chvt suspend suspend: success.
/usr/lib/pm-utils/sleep.d/90clock suspend suspend: success.
/usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend: success.
/usr/lib/pm-utils/sleep.d/95led suspend suspend: success.
/usr/lib/pm-utils/sleep.d/98smart-kernel-video suspend suspend: success.
/usr/lib/pm-utils/sleep.d/99hd-apm-restore.hook suspend suspend: saving level 128 for device sda
success.
/usr/lib/pm-utils/sleep.d/99video suspend suspend: success.
Mon Mar 16 23:34:00 GMT 2009: performing suspend
Comment 2 Matěj Cepl 2009-04-23 12:24:22 EDT
(In reply to comment #1)
> fglrx                2044772  22 

Thanks for the report. We are sorry that we cannot help you with your problem, but we are not able to support binary-only drivers. If you would be able to reproduce this issue using only open source software, please, reopen this bug with the additional information, but in meantime I have no choice than to close this bug as CANTFIX (because we really cannot fix it).

Note You need to log in before you can comment on or make changes to this bug.