Bug 490426 - Increasing clvmd memory consumption during vgscan
Increasing clvmd memory consumption during vgscan
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: lvm2-cluster (Show other bugs)
4
All Linux
urgent Severity medium
: rc
: ---
Assigned To: Milan Broz
Cluster QE
: ZStream
Depends On:
Blocks: 492601
  Show dependency treegraph
 
Reported: 2009-03-16 06:48 EDT by Milan Broz
Modified: 2013-02-28 23:07 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 488219
Environment:
Last Closed: 2009-05-18 17:11:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Broz 2009-03-16 06:48:59 EDT
+++ This bug was initially created as a clone of Bug #488219 +++
RHEL4 clone

Description of problem:

If periodically running vgscan in cluster (without any other loc operation),
memory consupmtion for clvmd increase and can cause OOM.

Caused by missing dm_pool_empty() call in VG context refresh path.

(possible workaround should be try to [re]activate some clustered LV,
this should flush the alocated pool data)

Version-Release number of selected component (if applicable):
lvm2-cluster-2.02.40-7.el5

How reproducible:
just run while :; do vgscan; done

and watch 
while :; do ps wax -o command,rss,vsz | grep [c]lv ; sleep 5 ; done

--- Additional comment from mbroz@redhat.com on 2009-03-05 11:29:56 EDT ---

Patch is in upstream cvs (for lvm2 2.02.46)
Comment 2 Milan Broz 2009-03-24 17:20:30 EDT
Fixed in lvm2-cluster-2.02.42-5.el4
Comment 7 errata-xmlrpc 2009-05-18 17:11:41 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1047.html

Note You need to log in before you can comment on or make changes to this bug.