Bug 490428 - rhn-solaris-bootstrap dependency issue when installing Satellite
rhn-solaris-bootstrap dependency issue when installing Satellite
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity low
: ---
: ---
Assigned To: Dennis Gilmore
Jan Hutař
:
Depends On:
Blocks: 457000
  Show dependency treegraph
 
Reported: 2009-03-16 08:00 EDT by Jan Hutař
Modified: 2009-09-10 15:41 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:41:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2009-03-16 08:00:45 EDT
Description of problem:
Depsolving problems with rhn_solaris_bootstrap when installing 530 nightly (with PyYAML already installed from EPEL).


Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090313.0


How reproducible:
2 of 2 attempts


Steps to Reproduce:
1. try to install Satellite


Actual results:
---> Package rhn-solaris-bootstrap.noarch 0:5.3.0-5.el5sat set to be updated
--> Processing Dependency: rhn_solaris_bootstrap_5_3_0_5 = 1-0.el5sat for package: rhn-solaris-bootstrap
--> Finished Dependency Resolution
rhn-solaris-bootstrap-5.3.0-5.el5sat.noarch from Satellite/rhn-solaris-bootstrap-5.3.0-5.el5sat.noarch.rpm has de
psolving problems
  --> Missing Dependency: rhn_solaris_bootstrap_5_3_0_5 = 1-0.el5sat is needed by package rhn-solaris-bootstrap-5
.3.0-5.el5sat.noarch (Satellite/rhn-solaris-bootstrap-5.3.0-5.el5sat.noarch.rpm)
Error: Missing Dependency: rhn_solaris_bootstrap_5_3_0_5 = 1-0.el5sat is needed by package rhn-solaris-bootstrap-
5.3.0-5.el5sat.noarch (Satellite/rhn-solaris-bootstrap-5.3.0-5.el5sat.noarch.rpm)


Expected results:
no dependency issues
Comment 1 Jan Hutař 2009-03-16 08:20:42 EDT
This is probably the issue:

# rpm -ihv /mnt/redhat/devel/candidate-trees/Satellite-5.3.0-RHEL5-re20090313.0/x86_64/x86_64/Satellite/rhn-solaris-bootstrap-5.3.0-5.el5sat.noarch.rpm
error: Failed dependencies:
	rhn_solaris_bootstrap_5_3_0_5 = 1-0.el5sat is needed by rhn-solaris-bootstrap-5.3.0-5.el5sat.noarch
Comment 2 Clifford Perry 2009-04-01 13:19:44 EDT
Dennis - I think this should already be addressed, getting Jan's Solaris packages from Friday into this ISO and comps. 

Cliff
Comment 3 Dennis Gilmore 2009-04-02 14:22:38 EDT
removed from 20090401
Comment 4 Jan Hutař 2009-04-06 06:27:00 EDT
Snapshot 20090401 installs ok on both RHEL5 and 4. Thanks.
Comment 5 Miroslav Suchý 2009-08-25 09:07:39 EDT
[root@xen5 rhn]# rpm -q rhn-solaris-bootstrap
rhn-solaris-bootstrap-5.3.0-10.el5sat.noarch

And no errors during install.
Verified in stage on xen5
Comment 6 Brandon Perkins 2009-09-10 15:41:12 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.