Bug 490611 - /usr/lib64/rhythmbox/plugins/artdisplay/__init__.py:128: Warning: Throbber animation not loaded: 'NoneType' object has no attribute 'get_base_size' warn ("Throbber animation not loaded: %s" % e, Warning)
/usr/lib64/rhythmbox/plugins/artdisplay/__init__.py:128: Warning: Throbber an...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 06:15 EDT by Michal Nowak
Modified: 2013-03-07 21:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 04:17:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
started rhythmbox (51.95 KB, image/png)
2009-03-24 09:46 EDT, Michal Nowak
no flags Details

  None (edit)
Description Michal Nowak 2009-03-17 06:15:00 EDT
Description of problem:

/usr/lib64/rhythmbox/plugins/artdisplay/__init__.py:128: Warning: Throbber animation not loaded: 'NoneType' object has no attribute 'get_base_size'
  warn ("Throbber animation not loaded: %s" % e, Warning)

is produced on start.

Version-Release number of selected component (if applicable):

rhythmbox-0.11.99.2-1.fc11.x86_64

How reproducible: 

always
Comment 1 Bastien Nocera 2009-03-23 14:31:51 EDT
Still a problem in rhythmbox 0.12.0?
Comment 2 Michal Nowak 2009-03-24 05:02:49 EDT
Yes, still present.
Comment 3 Bastien Nocera 2009-03-24 08:53:47 EDT
Which theme are you using? It's missing the gnome-spinner icon.
Comment 4 Michal Nowak 2009-03-24 09:45:32 EDT
Using the default one -- "Fedora". Where should be the "spinner" icon located? Attaching shot of rhythmbox.
Comment 5 Michal Nowak 2009-03-24 09:46:08 EDT
Created attachment 336468 [details]
started rhythmbox
Comment 6 Bastien Nocera 2009-04-14 11:26:58 EDT
Fedora inherits from Mist which inherits from gnome, and gnome (from gnome-icon-theme) has a gnome-spinner icon.

But this seems to fail:
                icon_info = self.icon_theme.lookup_icon (THROBBER, -1, 0)
Comment 7 Bastien Nocera 2009-04-14 12:58:40 EDT
I can't reproduce the problem here. My guess is that the icon cache isn't up-to-date, and it fails to find the gnome-spinner icon. Try running:
gtk-update-icon-cache -f /usr/share/icons/gnome
(and again for /usr/share/icons/Mist and /usr/share/icons/Fedora).
Comment 8 Michal Nowak 2009-04-15 04:17:51 EDT
Looks like it disappeared some time ago, probably the icon cache problem has been solved by icons pkg update.

Note You need to log in before you can comment on or make changes to this bug.