Bug 490657 - Traceback when mirrors fail
Traceback when mirrors fail
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:963c2b778aeada879...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 10:41 EDT by Orion Poplawski
Modified: 2009-11-20 16:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-20 16:59:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (97.08 KB, text/plain)
2009-03-17 10:41 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2009-03-17 10:41:25 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.31 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 786, in _getFile
    raise Errors.NoMoreMirrorsRepoError, errstr
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1474, in _retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 170, in populate
    db_fn = repo._retrieveMD(mydbtype)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 179, in _loadFiles
    self.sack.populate(self.repo, mdtype='filelists')
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 237, in returnFileTypes
    self._loadFiles()
  File "/usr/lib/anaconda/yuminstall.py", line 722, in getDownloadPkgs
    for filetype in po.returnFileTypes():
  File "/usr/lib/anaconda/yuminstall.py", line 1347, in doPostSelection
    (self.dlpkgs, self.totalSize, self.totalFiles)  = self.ayum.getDownloadPkgs()
  File "/usr/lib/anaconda/backend.py", line 276, in doPostSelection
    return anaconda.backend.doPostSelection(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 227, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1350, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/usr/lib/anaconda/gui.py", line 1513, in setup_window
    self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 1523, in run
    self.setup_window(runres)
  File "/usr/lib/anaconda/gui.py", line 1270, in run
    self.icw.run (self.runres)
  File "/usr/bin/anaconda", line 1017, in <module>
    anaconda.intf.run(anaconda)
NoMoreMirrorsRepoError: failure: repodata/698584b88bf5366be94651d65f6f6d30f186160a-filelists.sqlite.bz2 from rpmfusion-free: [Errno 256] No more mirrors to try.
Comment 1 Orion Poplawski 2009-03-17 10:41:30 EDT
Created attachment 335530 [details]
Attached traceback automatically from anaconda.
Comment 2 Orion Poplawski 2009-03-17 10:43:39 EDT
I think it would be nice if you were given an option to retry the download rather than crash.
Comment 3 Bug Zapper 2009-06-09 08:18:12 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Chris Lumens 2009-10-28 11:10:48 EDT
You should usually be given the option to retry things like this, yes.  The problem is that the increasing use of properties in yum makes it difficult for us to know where repos are going to get setup and where errors may occur, so we don't know where to add error handling.  Can you please test with F12 Beta again and let me know if this is still an issue, though?
Comment 5 Orion Poplawski 2009-11-20 16:59:49 EST
Things do seem much better now.  I'll reopen if it occurs again.

Note You need to log in before you can comment on or make changes to this bug.