Bug 490699 - Customers with valid entitlements but duplicate email addresses can not access support
Customers with valid entitlements but duplicate email addresses can not acces...
Status: CLOSED NOTABUG
Product: JBoss Customer Support Portal
Classification: Retired
Component: Accessibility (Show other bugs)
GovernanceBoard
All All
medium Severity urgent
: ---
: ---
Assigned To: JBoss CSP Bug Watch List
Tom Mirc
:
Depends On: 490991
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 13:22 EDT by Tom Mirc
Modified: 2010-06-18 17:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 490990 (view as bug list)
Environment:
Last Closed: 2010-06-18 17:21:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of new case dialog for user nbcjboss in STAGE (104.97 KB, image/png)
2009-03-19 12:28 EDT, David Spalding
no flags Details

  None (edit)
Description Tom Mirc 2009-03-17 13:22:32 EDT
Description of problem:

Users that have multiple accounts in CSP that use the same email for communication from each account can not access support from the CSP.  This issue has occurred 3 times since 5:00 pm 3/13.  Entitlements have been checked and are valid for support for at least one of the customer accounts in all 3 cases.   

On 3/13, Grant S. and team identified a bug fix for this that would correct the issue for all affected users, but it does not sound like we can easily obtain a report of how many customers are being affected by this.  

Version-Release number of selected component (if applicable):


How reproducible:
Log in as nbcjboss, spateli1 or yokomizo.osamu.  After selecting 'Support' and Open a New Case, no options are available to open a case.  The products the customer is entitled to do not show up, and the option "Other, product non listed" is also unavailable.  

Steps to Reproduce:
See above
  
Actual results:
No products available to open ticket against

Expected results:
Products customer is entitled to show up in support menu.

Additional info:
3 customers in 3 days have raised this issue.  I did an analysis of potential scope:

This bug could potentially have impact on 800 users, who use the same email address for multiple accounts.  A total of 1783 usernames are impacted. The usernames who may be impacted are attached.
Comment 2 Nathan Lugert 2009-03-17 15:25:04 EDT
SSOCookie.getLogin returns the email address and SSOCookie.getId return the actual login. This was the result of removing a parameter from the actual cookie value string but not adjusting for that in the SSOCookie class. Changed the CSP login code to get the SSOCookie.getId (login). This fixes the error where users were being logged in via their email address and missing entitlements. csp-mr9 branch version 4687.
Comment 3 David Spalding 2009-03-17 16:50:47 EDT
Changed to NEW and GOVERNANCEBOARD since we are pushing this out as an 
emergency fix.
Comment 4 David Spalding 2009-03-17 16:51:23 EDT
Changed to ASSIGNED and GOVERNANCEBOARD since we are pushing this out as an 
emergency fix.
Comment 5 David Spalding 2009-03-19 12:28:10 EDT
Created attachment 335884 [details]
Screenshot of new case dialog for user nbcjboss in STAGE

Verified in STAGE environment:

1. Logged in to www.stage.redhat.com/wapps/sso/jboss/login.html as nbcjboss.
2. Bounced to Production. 
3. Browsed to https://support.stage.redhat.com/jbossnetwork/login.html

=> Viewed open cases. 

https://support.stage.redhat.com/jbossnetwork/restricted/listCases.html

4. Browsed to "new case" -> support.stage.redhat.com/jbossnetwork/restricted/addCase.html

=> Case dialog opens with ability to file new case.
Comment 6 David Spalding 2009-03-19 12:37:40 EDT
Confirmed by NLugert.
Comment 7 David Spalding 2010-06-16 17:34:03 EDT
Any idea of the status of this bug?
Comment 8 Nathan Lugert 2010-06-17 10:02:07 EDT
This is no longer an issue that I'm aware of. Let me know if you want me to close it.
Comment 9 David Spalding 2010-06-18 17:21:20 EDT
Closed as per comment #8. ;)

Note You need to log in before you can comment on or make changes to this bug.