Bug 490735 - nl_cache_get_first() error strings on console during text install
nl_cache_get_first() error strings on console during text install
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
i686 Linux
low Severity medium
: rc
: ---
Assigned To: David Cantrell
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 14:58 EDT by Charlie Brady
Modified: 2009-09-02 05:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:55:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing errant messages on console. (195.10 KB, image/png)
2009-03-23 13:06 EDT, Charlie Brady
no flags Details

  None (edit)
Description Charlie Brady 2009-03-17 14:58:45 EDT
When booted in VMware in text mode, anaconda report following just before 
switching to snack mode:

Running anaconda, the CentOS system installer - please wait...
nl_cache_get_first() failure in nl_ip2str(): No such file or directory
Probing for video card:  VMWare Inc Abstract SVGA II adapter

When VM has three NICs, I see:

Running anaconda, the CentOS system installer - please wait...
nl_cache_get_first() failure in nl_ip2str(): No such file or directory
nl_cache_get_first() failure in nl_ip2str(): Illegal seek
nl_cache_get_first() failure in nl_ip2str(): Illegal seek
Probing for video card:  VMWare Inc Abstract SVGA II adapter
Comment 1 Charlie Brady 2009-03-17 15:03:51 EDT
The 'No such file or directory' and 'Illegal seek' parts of the message are bogus, from inappropriate use of perror() in this code (in isys/iface.c):

...
      /* find the IPv4 and IPv6 addresses for this interface */
      if ((obj = nl_cache_get_first(cache)) == NULL) {
          perror("nl_cache_get_first() failure in nl_ip2str()");
          goto ip2str_error;
      }
...

The  NULL return from nl_cache_get_first() is due to a cache miss, not a
system call error return, and errno is not set, so perror() isn't appropriate.

In any case, I think treating the cache miss as an error is wrong - none of the interfaces have IP addresses, AFAICT.

I've found this patch which removes the error message (amongst many other changes):

http://dcantrel.fedorapeople.org/anaconda/iface/pro-NetworkManager/anaconda-11.4.1.1-NetworkManager.patch
Comment 2 Charlie Brady 2009-03-17 15:15:06 EDT
And this patch gets rid of the nl_cache lookups, and uses dbus:

http://git.fedorahosted.org/git/anaconda.git?p=anaconda.git;a=commitdiff;h=debfe5428f1ed5f4464511027cc5077efaca7d5a


Simplest fix for this cosmetic issue however is just to remove the perror() calls.
Comment 3 Charlie Brady 2009-03-17 15:16:27 EDT
I'm a little surprised that nobody else has reported this issue.
Comment 4 David Cantrell 2009-03-17 17:49:11 EDT
Similar to bug #466305, but this is different.  I have no problems fixing up cosmetic issues like this.  The libnl + libdhcp networking code in RHEL 5 is no longer what we're doing in Fedora.  We've moved to using NetworkManager and DBus, so it's unlikely you'll be able to find anything worth backporting.
Comment 5 RHEL Product and Program Management 2009-03-17 17:58:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Charlie Brady 2009-03-23 12:27:06 EDT
(In reply to comment #4)
> Similar to bug #466305, but this is different.  I have no problems fixing up
> cosmetic issues like this.

Can bug 466305 be made publicly viewable?
Comment 8 Charlie Brady 2009-03-23 13:06:35 EDT
Created attachment 336330 [details]
Screenshot showing errant messages on console.
Comment 9 David Cantrell 2009-05-04 16:44:27 EDT
Fix will be in anaconda-11.1.2.172-1 and later.
Comment 12 Alexander Todorov 2009-07-07 10:05:16 EDT
Charlie,
can you give RHEL 5.4 beta a try on VMware? If you have active RHN subscription you can download the bits.
Comment 13 Alexander Todorov 2009-08-03 06:03:03 EDT
I've borrowed a VMware served from anaconda team in Brno and I can't reproduce. There's no nl_cache_get_first() errors on tty1.
Comment 15 errata-xmlrpc 2009-09-02 05:55:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1306.html

Note You need to log in before you can comment on or make changes to this bug.