Bug 490739 - anaconda probes for non-existing fd0 for 10 minutes
anaconda probes for non-existing fd0 for 10 minutes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 494832
  Show dependency treegraph
 
Reported: 2009-03-17 15:18 EDT by Patrick C. F. Ernzer
Modified: 2009-04-29 15:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 15:30:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/storage.log from anaconda 11.5.0.35 (9.33 KB, text/plain)
2009-03-24 09:15 EDT, Patrick C. F. Ernzer
no flags Details

  None (edit)
Comment 3 Chris Lumens 2009-03-17 16:30:39 EDT
This looks like it could be a pyparted bug, but the log message that makes me think this ("creating parted Disk /dev/fd0") could also be a red herring.  Please test tomorrow's build of anaconda which will move this log message to the right place and attach a new storage.log so we can see what's really going on.  Thanks.
Comment 4 David Cantrell 2009-03-23 16:08:31 EDT
Patrick,

Have you been able to try the latest nightly rawhide tree to see if this problem is still present?
Comment 5 Patrick C. F. Ernzer 2009-03-24 09:15:07 EDT
Created attachment 336458 [details]
/tmp/storage.log from anaconda 11.5.0.35

problem persists with anaconda 11.5.0.35, seet attached storage.log
storage.log was retrieved from the node after waiting for the timeout on fd0 and then clicking 'ignore drive'.
Comment 6 Ray Todd Stevens 2009-03-24 18:31:32 EDT
As of today this problem still exists.   Running from preupgrade if that helps.
Comment 7 Patrick C. F. Ernzer 2009-03-27 10:31:56 EDT
problem still exists in anaconda 11.5.0.38
Comment 8 Ray Todd Stevens 2009-04-01 16:22:18 EDT
Interesting.   I tried to do an upgrade using the netboot method instead of preupgrade, which is broken because of another bug.

When I go into the secondary ctrl alt screens I find that it is apparently trying to format the floppy drive.   With each track erroring out.   If you had a disk in the drive that was just not fedora compatible that could really be a bad issue.
Comment 9 Patrick C. F. Ernzer 2009-04-02 10:22:17 EDT
problem still exists with anaconda 11.5.0.38
Comment 10 Ray Todd Stevens 2009-04-02 15:46:14 EDT
This problem also occurs when trying to get into rescue mode.
Comment 11 A. Mani 2009-04-11 17:36:47 EDT
This is the same as/ related to 


https://bugzilla.redhat.com/show_bug.cgi?id=493377
Comment 12 Patrick C. F. Ernzer 2009-04-21 13:13:04 EDT
I can confirm that this bug is fixed in anaconda 11.5.0.46
Thanks Chris.
This bug can be CLOSED RAWHIDE
Comment 13 Ray Todd Stevens 2009-04-21 13:19:20 EDT
How does one access these new versions of anaconda for testing?
Comment 14 Ray Todd Stevens 2009-04-21 13:36:54 EDT
Actually I should probably make my question more specific.   I understand the update.img thing and how to use it, but where would find the right update.img thing to use the right anaconda.
Comment 15 David Cantrell 2009-04-21 21:36:49 EDT
Closing per comment #12.
Comment 16 Patrick C. F. Ernzer 2009-04-29 14:33:38 EDT
this bug is back in F11 Preview (anaconda 11.5.0.47) but at least after the 10 minute wait I can now click ignore after 10ish minutes and continue install.

For F11 I'm kinda sorta OK as I only see this on one hardware variant, but this needs to be resolved by RHEL 6 or the customer I am sitting at will be VeryUnhappy(tm)

What can I do to make this bug once again go away?
Comment 17 Patrick C. F. Ernzer 2009-04-29 14:40:56 EDT
aaah, Haisenbugs, don't we love them

same anaconda version but with latest rawhide from my mirror, error is gone again.

Not quite sure what to do now.
Comment 19 Patrick C. F. Ernzer 2009-04-29 15:30:38 EDT
nevermind, I am an idiot.
Comment #16 and #18 were done with the kernel & initrd of F11 Preview but the ks file pointed at F11 Beta (my punishment for copying old ks files and then editing them or as in this case forgetting to edit them).
Sorry about the noise. All is well WRT this bug in F11 Preview.

Note You need to log in before you can comment on or make changes to this bug.