Bug 490757 - Review Request: grib_api - WMO FM-92 GRIB (v1,v2) interface accessible from C and FORTRAN programs
Review Request: grib_api - WMO FM-92 GRIB (v1,v2) interface accessible from C...
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 16:25 EDT by Jeroen van Meeuwen
Modified: 2009-03-17 20:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 18:39:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeroen van Meeuwen 2009-03-17 16:25:59 EDT
Spec URL: http://www.kanarip.com/custom/SPECS/grib_api.spec
SRPM URL: http://www.kanarip.com/custom/f11/SRPMS/grib_api-1.7.0-1.fc11.src.rpm
Description: The ECMWF GRIB API is an application program interface accessible from C and FORTRAN programs developed for encoding and decoding WMO FM-92 GRIB edition 1 and edition 2 messages. A useful set of command line tools is also provided to give quick access to grib messages.

rpmlint says:

$ rpmlint /home/jmeeuwen/rpmbuild/RPMS/x86_64/grib_api-*
/usr/share/rpmlint/Pkg.py:16: DeprecationWarning: The popen2 module is deprecated.  Use the subprocess module.
  import popen2
grib_api.x86_64: W: incoherent-version-in-changelog 2.6.4-1 ['1.7.0-1.fc11', '1.7.0-1']
grib_api-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/grib_api-1.7.0/src/grib_trie.c
grib_api-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/grib_api-1.7.0/tigge/tigge_accumulations.c
grib_api-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/grib_api-1.7.0/tools/parser.c
grib_api-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/grib_api-1.7.0/src/action_class_write.c
grib_api-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/grib_api-1.7.0/src/grib_itrie.c
grib_api-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/grib_api-1.7.0/tigge/tigge_name.c
grib_api-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/grib_api-1.7.0/src/action_class_while.c
grib_api-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/grib_api-1.7.0/src/grib_accessor_class_g1domain.c
grib_api-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/grib_api-1.7.0/tigge/tigge_check.c
grib_api-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/grib_api-1.7.0/src/grib_accessor_class_times.c
grib_api-debuginfo.x86_64: W: spurious-executable-perm /usr/src/debug/grib_api-1.7.0/tigge/tigge_split.c
4 packages and 0 specfiles checked; 0 errors, 12 warnings.

I don't know how to fix the debug/* files.

Some koji scratch builds:

- dist-f9-updates-candidate: http://koji.fedoraproject.org/koji/taskinfo?taskID=1246658
- dist-f10-updates-candidate: http://koji.fedoraproject.org/koji/taskinfo?taskID=1246663 
- dist-f11-updates-candidate: http://koji.fedoraproject.org/koji/taskinfo?taskID=1246668
Comment 1 Jason Tibbitts 2009-03-17 18:13:14 EDT
This is already in the distro, isn't it?
Comment 2 Jason Tibbitts 2009-03-17 18:39:08 EDT
Sure seems to be.

> yum info grib_api
Available Packages
Name       : grib_api
Arch       : x86_64
Version    : 1.6.4
Release    : 1.fc10
Size       : 4.2 M
Repo       : updates
Summary    : ECMWF encoding/decoding GRIB software
URL        : http://www.ecmwf.int/products/data/software/grib_api.html
License    : LGPLv3
Description: Command line tools for interactive and batch processing
           : of GRIB (GRIdded Binary) data.

*** This bug has been marked as a duplicate of bug 427121 ***
Comment 3 Jeroen van Meeuwen 2009-03-17 20:31:42 EDT
This is packaged already, my mistake

Note You need to log in before you can comment on or make changes to this bug.