Bug 490759 - Improper /etc/alternatives/libjavaplugin.so symlink
Improper /etc/alternatives/libjavaplugin.so symlink
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: java-1.6.0-sun (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Deepak Bhole
BaseOS QE
:
: 561463 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 16:40 EDT by Dax Kelson
Modified: 2010-06-30 15:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 15:28:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2009-03-17 16:40:59 EDT
Description of problem:
On a 64bit system with the following packages installed:

java-1.6.0-sun-devel-1.6.0.12-1jpp.3.el5.x86_64
java-1.6.0-sun-jdbc-1.6.0.12-1jpp.3.el5.x86_64
java-1.6.0-sun-1.6.0.12-1jpp.3.el5.x86_64

And importantly both 32bit and 64bit Java applet rpms:

java-1.6.0-sun-plugin-1.6.0.12-1jpp.3.el5.x86_64
java-1.6.0-sun-plugin-1.6.0.12-1jpp.3.el5.i586

The i586 plugin package doesn't install properly.

In the postinstall scriptlet it uses the wrong path with the update-alternatives command.

The current (broken) invocation is:

update-alternatives --install /usr/lib/mozilla/plugins/libjavaplugin.so libjavaplugin.so /usr/lib/jvm/jre-1.6.0-sun/plugin/i386/ns7/libjavaplugin_oji.so

                              ^^^^^^^^^^^^^ BUT this points to the 64bit JVM by way of /etc/alternatives.

The part identified above should be instead "java-1.6.0-sun-1.6.0.12/jre".

The other files under /etc/alternatives control, /usr/share/javaws, /usr/bin/ControlPanel, and /usr/share/man/man1/javaws.1.gz have the same issue with the ControlPanel link having an additional problem of being a dangling symlink unless the java-1.6.0-sun.i586 is also installed.
Comment 1 Lillian Angel 2009-03-18 10:30:51 EDT
This link is not incorrect, and it does exist on a 32-bit system: /usr/lib/jvm/jre-1.6.0-sun/plugin/i386/ns7/libjavaplugin_oji.so. I am unsure why you are not seeing it. What packages do you have installed?
Comment 2 Dax Kelson 2009-03-18 10:54:31 EDT
java-1.6.0-sun-devel-1.6.0.12-1jpp.3.el5.x86_64
java-1.6.0-sun-jdbc-1.6.0.12-1jpp.3.el5.x86_64
java-1.6.0-sun-1.6.0.12-1jpp.3.el5.x86_64
java-1.6.0-sun-plugin-1.6.0.12-1jpp.3.el5.x86_64
java-1.6.0-sun-plugin-1.6.0.12-1jpp.3.el5.i586
Comment 3 Lillian Angel 2009-03-18 11:23:23 EDT
Ah I understand now. These packages are not multilib, and installing both in parallel may not work.

related to this bug: https://bugzilla.redhat.com/show_bug.cgi?id=340391
Comment 11 Deepak Bhole 2010-02-17 11:38:44 EST
*** Bug 561463 has been marked as a duplicate of this bug. ***
Comment 12 Deepak Bhole 2010-06-30 15:28:08 EDT
I see both, i586 and x86_64 plugin packages on RHN now. I take it it works?

If not, please feel free to re-open.

Note You need to log in before you can comment on or make changes to this bug.