Bug 490774 - Azureus doesn't start on 64-bit platforms
Azureus doesn't start on 64-bit platforms
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
rawhide
x86_64 Linux
urgent Severity medium
: ---
: ---
Assigned To: Conrad Meyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 18:26 EDT by Bart Vanbrabant
Modified: 2009-03-19 13:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 13:41:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the bug (1.42 KB, patch)
2009-03-18 05:10 EDT, Bart Vanbrabant
no flags Details | Diff

  None (edit)
Description Bart Vanbrabant 2009-03-17 18:26:54 EDT
Description of problem:
Eclipse doesn't start because it can't find the needed swt.jar library.  azureus.script has a hardcoded path to /usr/lib/eclipse/swt.jar

On 64-bit platforms this jar is located in /usr/lib64/eclipse/swt.jar

Version-Release number of selected component (if applicable):
azureus-4.0.0.4-2.fc11.noarch


The attached patch fixes azureus.script
Comment 1 Conrad Meyer 2009-03-17 18:53:25 EDT
Sorry, what attached patch?
Comment 2 Bart Vanbrabant 2009-03-18 05:10:14 EDT
Created attachment 335668 [details]
Patch to fix the bug
Comment 3 Bart Vanbrabant 2009-03-18 05:10:45 EDT
I attached one now, seems I did something wrong.
Comment 4 Conrad Meyer 2009-03-18 23:08:18 EDT
Thanks, looks good.
Comment 5 Conrad Meyer 2009-03-18 23:13:11 EDT
Building in Koji:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1249329
Comment 6 Conrad Meyer 2009-03-18 23:36:29 EDT
Ok, it finished -- want to test it?
Comment 7 Conrad Meyer 2009-03-18 23:42:33 EDT
Seems to work ok for me.
Comment 8 Bart Vanbrabant 2009-03-19 10:31:50 EDT
Works for me as well. This bug can be closed.
Comment 9 Conrad Meyer 2009-03-19 13:41:40 EDT
Thanks for reporting it and for the patch.

Note You need to log in before you can comment on or make changes to this bug.