Bug 490823 - Ettercap segfaults when starting to sniff
Ettercap segfaults when starting to sniff
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ettercap (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-18 03:50 EDT by Aioanei Rares
Modified: 2009-05-12 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 12:53:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aioanei Rares 2009-03-18 03:50:40 EDT
Description of problem:

Ettercap segfaults when starting to sniff in curses mode (unified sniffing)

Version-Release number of selected component (if applicable):

ettercap NG-0.7.3


How reproducible:

Everytime

Steps to Reproduce:
1.Start ettercap with sudo ettercap -C
2.Press 'U' (capital u)
3.Select start sniffing from start menu
  
Actual results:

Segfault

Expected results:

A working sniff

Additional info:
Comment 1 Gwyn Ciesla 2009-03-18 08:26:03 EDT
Could you provide a stack trace?

http://fedoraproject.org/wiki/StackTraces

You can install yum-utils and then use debuginfo-install ettercap.

Thanks!
Comment 2 Aioanei Rares 2009-03-18 08:34:48 EDT
(In reply to comment #1)
> Could you provide a stack trace?
> 
> http://fedoraproject.org/wiki/StackTraces
> 
> You can install yum-utils and then use debuginfo-install ettercap.
> 
> Thanks!  

sudo debuginfo-install ettercap
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * updates-testing: ftp.linux.cz
 * rpmfusion-nonfree-updates: ftp.nb.lug.ro
 * fedora: ftp.linux.cz
 * rpmfusion-free-updates: ftp.nb.lug.ro
 * rpmfusion-free: ftp.nb.lug.ro
 * fedora-debuginfo: ftp.linux.cz
 * updates: ftp.linux.cz
 * fedora-source: ftp.linux.cz
 * rpmfusion-nonfree: ftp.nb.lug.ro
enabling updates-testing-debuginfo
Checking for new repos for mirrors
 * updates-testing-debuginfo: ftp.SURFnet.nl
Reading repository metadata in from local files
updates-testing-debuginfo                                | 1.9 kB     00:00     
updates-testing-debuginfo/primary_db                     |  43 kB     00:00     
enabling rpmfusion-nonfree-updates-debuginfo
Checking for new repos for mirrors
 * rpmfusion-nonfree-updates-debuginfo: ftp.nb.lug.ro
Reading repository metadata in from local files
rpmfusion-nonfree-updates-debuginfo                      | 2.1 kB     00:00     
rpmfusion-nonfree-updates-debuginfo/primary_db           |  17 kB     00:00     
enabling fedora-debuginfo
Checking for new repos for mirrors
Reading repository metadata in from local files
enabling rpmfusion-free-updates-debuginfo
Checking for new repos for mirrors
 * rpmfusion-free-updates-debuginfo: ftp.nb.lug.ro
Reading repository metadata in from local files
rpmfusion-free-updates-debuginfo                         | 2.1 kB     00:00     
rpmfusion-free-updates-debuginfo/primary_db              |  25 kB     00:00     
enabling rpmfusion-free-debuginfo
Checking for new repos for mirrors
 * rpmfusion-free-debuginfo: ftp.nb.lug.ro
Reading repository metadata in from local files
rpmfusion-free-debuginfo                                 | 2.1 kB     00:00     
rpmfusion-free-debuginfo/primary_db                      |  38 kB     00:00     
enabling updates-debuginfo
Checking for new repos for mirrors
 * updates-debuginfo: ftp.SURFnet.nl
Reading repository metadata in from local files
updates-debuginfo                                        | 1.9 kB     00:00     
updates-debuginfo/primary_db                             | 339 kB     00:00     
enabling rpmfusion-nonfree-debuginfo
Checking for new repos for mirrors
 * rpmfusion-nonfree-debuginfo: ftp.nb.lug.ro
Reading repository metadata in from local files
rpmfusion-nonfree-debuginfo                              | 2.1 kB     00:00     
rpmfusion-nonfree-debuginfo/primary_db                   |  14 kB     00:00     
No debuginfo packages available to install
Comment 3 Gwyn Ciesla 2009-03-18 08:58:10 EDT
What about ettercap-debuginfo?
Comment 4 Aioanei Rares 2009-03-18 09:24:33 EDT
(In reply to comment #3)
> What about ettercap-debuginfo?  

Ok, I installed ettercap-debuginfo, but what gdb spews isn't understandable
at any cost and as a plus it leaves my terminal in an unusable state.
Comment 5 Gwyn Ciesla 2009-03-18 10:29:36 EDT
If you install the debuginfo for another app (maybe try something innocuous, say, gedit or the Gimp), does gdb do something rational?
Comment 6 Aioanei Rares 2009-03-18 11:04:35 EDT
(In reply to comment #5)
> If you install the debuginfo for another app (maybe try something innocuous,
> say, gedit or the Gimp), does gdb do something rational?  

Yes it does, since such apps are gtk-based, not curses-based like ettercap invoked with the -C flag...what worries me are messages like the following :

warning: the debug information found in "/usr/lib/debug//usr/lib64/gimp/2.0/modules/libdisplay-filter-lcms.so.debug" does not match "/usr/lib64/gimp/2.0/modules/libdisplay-filter-lcms.so" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug/usr/lib64/gimp/2.0/modules/libdisplay-filter-lcms.so.debug" does not match "/usr/lib64/gimp/2.0/modules/libdisplay-filter-lcms.so" (CRC mismatch).

which I see in running gimp and I've seen also with ettercap. Not all apps
are subject to this CRC mismatch error (e.g. gnome-terminal or mc)
Comment 7 Gwyn Ciesla 2009-03-18 11:11:46 EDT
Ok, try nethack or mc, those are ncurses-based also.

Not sure that the CRC errors are about.
Comment 8 Aioanei Rares 2009-03-18 11:29:06 EDT
(In reply to comment #7)
> Ok, try nethack or mc, those are ncurses-based also.
> 
> Not sure that the CRC errors are about.  

mc works, nethack I haven't tried, but I guess it's not curses-related.
Comment 9 Gwyn Ciesla 2009-03-18 11:33:57 EDT
Can you capture any of the ettercap gdb output?
Comment 10 Aioanei Rares 2009-03-18 11:50:07 EDT
(In reply to comment #9)
> Can you capture any of the ettercap gdb output?  

Nope...
Comment 11 Gwyn Ciesla 2009-03-18 12:19:01 EDT
Screenshot?
Comment 12 Aioanei Rares 2009-03-18 12:49:09 EDT
(In reply to comment #11)
> Screenshot?  

Tomorrow.
Comment 13 Aioanei Rares 2009-03-18 12:55:48 EDT
(In reply to comment #12)
> (In reply to comment #11)
> > Screenshot?  
> 
> Tomorrow.  

...or today...now ettercap won't even start.

Starting program: /usr/bin/ettercap ettercap -C
[Thread debugging using libthread_db enabled]

ettercap NG-0.7.3 copyright 2001-2004 ALoR & NaGA


TARGET (ettercap) contains invalid chars !


Program exited with code 0377.

But it works apparently ok when started normally.
Comment 14 Gwyn Ciesla 2009-03-18 13:57:28 EDT
What does started normally mean?
Comment 15 Aioanei Rares 2009-03-18 14:16:08 EDT
(In reply to comment #14)
> What does started normally mean?  

Works as it's supposed to.
Comment 16 Gwyn Ciesla 2009-03-18 14:17:53 EDT
I mean, what are you typing to run ettercap?  

ettercap -C

/usr/bin/ettercap -C

Something else?
Comment 17 Aioanei Rares 2009-03-18 14:32:08 EDT
(In reply to comment #16)
> I mean, what are you typing to run ettercap?  
> 
> ettercap -C
> 
> /usr/bin/ettercap -C
> 
> Something else?  

ettercap -C
Comment 18 Gwyn Ciesla 2009-03-23 13:42:01 EDT
Any luck on a screenshot?
Comment 19 Gwyn Ciesla 2009-04-13 14:06:01 EDT
Ping?
Comment 20 Gwyn Ciesla 2009-04-21 09:43:10 EDT
I can't reproduce this.  If I don't see additional information to help me troubleshoot, I'll have to close.
Comment 21 Gwyn Ciesla 2009-05-12 12:53:56 EDT
Can't reproduce.

Note You need to log in before you can comment on or make changes to this bug.