Bug 490864 - NetworkManager 0.7.0.99 update has broken mobile broadband connectivity
NetworkManager 0.7.0.99 update has broken mobile broadband connectivity
Status: CLOSED DUPLICATE of bug 487663
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-18 07:45 EDT by Graham Cox
Modified: 2009-03-18 09:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-18 09:23:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Cox 2009-03-18 07:45:25 EDT
Description of problem:
Since updating NetworkManager to 0.7.0.99 (which was provided as an update in F10 stable in early March), I am no longer able to connect to my mobile broadband provider using the Huawei E169 USB key/modem.

Version-Release number of selected component (if applicable):
NetworkManager 0.7.0.99

How reproducible:
Clicking on NetworkManager icon in system tray and selecting "Auto GSM Connection" leads to F10 attempting to connect, but the connection fails.

Additional info:
Uninstalling NetworkManager, NetworkManager-glib and NetworkManager-gnome 0.7.0.99 and replacing all three files with version 0.7.0-2.git20090207.fc10.i386 resolves this issue.

The connection works without any issues with previous versions of NetworkManager and in Ubuntu 8.10.

/var/log/messages:

NetworkManager: <info>  (ttyUSB2): detected GSM modem via udev capabilities
NetworkManager: <info>  (ttyUSB2): new Modem device (driver: 'option')
NetworkManager: <info>  (ttyUSB2): exported as /org/freedesktop/Hal/devices/usb_device_12d1_1001_____________________if2_serial_usb_2
NetworkManager: <info>  (ttyUSB0): device state change: 1 -> 2
NetworkManager: <info>  (ttyUSB0): deactivating device (reason: 2).
NetworkManager: nm_system_device_flush_ip4_routes_with_iface: assertion `iface_idx >= 0' failed
NetworkManager: <info>  (ttyUSB2): device state change: 2 -> 3
NetworkManager: <info>  Activation (ttyUSB0) starting connection 'Auto GSM network connection'
NetworkManager: <info>  (ttyUSB0): device state change: 3 -> 4
NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
NetworkManager: <WARN>  check_pin_done(): PIN checking timed out
NetworkManager: <info>  (ttyUSB0): device state change: 4 -> 9
NetworkManager: <info>  Marking connection 'Auto GSM network connection' invalid.
NetworkManager: <info>  Activation (ttyUSB0) failed.
NetworkManager: <info>  (ttyUSB0): device state change: 9 -> 3
NetworkManager: <info>  (ttyUSB0): deactivating device (reason: 0).
NetworkManager: nm_system_device_flush_ip4_routes_with_iface: assertion `iface_idx >= 0' failed
NetworkManager: nm_system_device_flush_ip4_addresses_with_iface: assertion `iface_idx >= 0' failed
Comment 1 Dan Williams 2009-03-18 09:23:07 EDT

*** This bug has been marked as a duplicate of bug 487663 ***

Note You need to log in before you can comment on or make changes to this bug.