Bug 490906 - slow boot/shutdown with -135.el5debug kernel as xen guest
slow boot/shutdown with -135.el5debug kernel as xen guest
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-18 10:51 EDT by Jeff Layton
Modified: 2014-06-18 03:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-27 10:27:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2009-03-18 10:51:06 EDT
I've got a RHEL5 FV xen guest that I use for testing. When I boot it with a -135.el5debug kernel, sometimes it seems to boot and shut down very slowly (i.e. takes twice as long or longer. This doesn't happen on every boot, but maybe around half the time.

The symptoms are mainly that it just takes a very long time to boot when this happens, the serial console seems to scroll more slowly, and shutdown can take ages. The frustrating bit is that it doesn't occur on every reboot, and I'm not clear as to why...

I suspect that the problem is due to this commit in Don Z's tree:

161f54d06c46c74476e1bdbc24aaa0c8799da083

Subject: [RHEL5 PATCH] [x86_64] fix gettimeoday TSC overflow issue

...I've never been able to reproduce the problem without that patch in the guest kernel. I've also never seen the problem occur on pre -135.el5debug kernels.
Comment 1 Chris Lalancette 2009-03-27 09:57:54 EDT
Jeff,
     Given what we know here, it seems like -136 should fix this up.  If you get a chance, can you give it a whirl and then we can close this out?

Thanks,
Chris Lalancette
Comment 2 Jeff Layton 2009-03-27 10:27:46 EDT
Yep. I've been running a -136 kernel on that guest for a bit and it seems to be fine. Before that I also ran kernels with the TSC patch pulled and they were fine. Since Don has pulled that patch for the time being, I think we can go ahead and close this.

I guess CURRENTRELEASE is the right resolution here...

Note You need to log in before you can comment on or make changes to this bug.