Bug 490935 - Songs aren't played in random order in queue when shuffle is set
Songs aren't played in random order in queue when shuffle is set
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-18 12:01 EDT by Michal Nowak
Modified: 2013-03-07 21:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 18:39:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2009-03-18 12:01:10 EDT
Description of problem:

Insert few song in Play Queue (~30 in my case), start playing, wait for next song, or hit "Next" button, the song is *always* the "next" on in the list, not random one.

Happens only in "Play Queue", not "Music".

I guess this worked as I expect in older version in Rhythmbox, in case it's intended not to shuffle the queue, disable the Shuffle button & menu item.

Version-Release number of selected component (if applicable):

rhythmbox-0.11.99.3-1.fc11.x86_64

How reproducible:
always
Comment 1 Bastien Nocera 2009-03-19 18:39:21 EDT
This is by design. File a bug upstream at http://bugzilla.gnome.org if you feel strongly about it.

Note You need to log in before you can comment on or make changes to this bug.