Bug 490947 - PrettyPrintCrl throws exceptions
PrettyPrintCrl throws exceptions
Status: CLOSED ERRATA
Product: Dogtag Certificate System
Classification: Community
Component: ESC (Show other bugs)
unspecified
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Harmsen
Chandrasekar Kannan
: Reopened
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2009-03-18 12:42 EDT by Kashyap Chamarthy
Modified: 2015-01-04 18:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 19:33:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
MasterCRL.bin file for which no revoked certs are shown. (407 bytes, application/octet-stream)
2009-03-18 14:26 EDT, Kashyap Chamarthy
no flags Details
PrettyPrint scripts (13.41 KB, patch)
2009-03-26 20:48 EDT, Matthew Harmsen
no flags Details | Diff
PrettyPrint scripts (specs) (983 bytes, patch)
2009-03-26 20:50 EDT, Matthew Harmsen
no flags Details | Diff

  None (edit)
Description Kashyap Chamarthy 2009-03-18 12:42:30 EDT
Description of problem:

When I try to view MasterCrl.bin file generated via 
"wget --no-check-certificate -d https://peach.pnq.redhat.com:9444/ca/ee/ca/crl/MasterCRL.bin" , I get exceptions.



Version-Release number of selected component (if applicable):

pki-java-tools-8.0.0-10.alpha  (Build Date - 17 march 2009)


Steps-to-reproduce:

(1) Go to the directory where you have MasterCrl.bin and issue the below command

[csuser1@peach ~]$ PrettyPrintCrl MasterCRL.bin .
Exception in thread "main" java.lang.NullPointerException
        at java.io.ByteArrayInputStream.<init>(ByteArrayInputStream.java:106)
        at netscape.security.util.DerValue.<init>(DerValue.java:236)
        at netscape.security.x509.X509CRLImpl.<init>(X509CRLImpl.java:132)
        at com.netscape.cmstools.PrettyPrintCrl.main(PrettyPrintCrl.java:144)

  
Expected results:
Should be able to see CRL information.

Please let me know if any other information is required.
Comment 1 Kashyap Chamarthy 2009-03-18 14:26:45 EDT
Created attachment 335748 [details]
MasterCRL.bin file for which no revoked certs are shown.

Created an attachment of MasterCRL.bin
Comment 3 Kashyap Chamarthy 2009-03-24 16:44:13 EDT
Not a bug.
need to first convert .bin to ASCII using BtoA and later PrettyPrintCrl the ascii file.
Comment 4 Matthew Harmsen 2009-03-26 20:06:12 EDT
Although this is still not a bug, the following attachment outlines some simple fixes to the generated shell scripts for PrettyPrintCert and PrettyPrintCrl.
Comment 5 Matthew Harmsen 2009-03-26 20:48:46 EDT
Created attachment 336933 [details]
PrettyPrint scripts
Comment 6 Matthew Harmsen 2009-03-26 20:50:20 EDT
Created attachment 336934 [details]
PrettyPrint scripts (specs)
Comment 7 Andrew Wnuk 2009-03-26 20:54:03 EDT
attachment (id=336933)
attachment (id=336934)
+awnuk
Comment 8 Matthew Harmsen 2009-03-26 20:59:01 EDT
% svn stat
M      dogtag/java-tools/pki-java-tools.spec
A      base/java-tools/templates/pretty_print_crl_command_wrapper
A      base/java-tools/templates/pretty_print_cert_command_wrapper
M      base/java-tools/build.xml

%svn commit
Sending        base/java-tools/build.xml
Adding         base/java-tools/templates/pretty_print_cert_command_wrapper
Adding         base/java-tools/templates/pretty_print_crl_command_wrapper
Sending        dogtag/java-tools/pki-java-tools.spec
Transmitting file data ....
Committed revision 339.
Comment 9 Kashyap Chamarthy 2009-06-01 06:44:58 EDT
Verified(with build 20 may 09). PrettyPrintCrl prints the certificate gracefully.

Note You need to log in before you can comment on or make changes to this bug.